Auto cut empty midi?

Hello!
I’m tired to everytime cut empty midi part before and after i play. Cubase always fill empty space on track with long empty midi part…

Can it be turned off ? or maybe macro to cut everything before 1st midi note.

i want record midi same as audio - You press record, audio part start writing, press stop part stops writing.
maybe i miss something in preferences.

Hi,

There is a Preferences > Record > MIDI > Snap MIDI Parts to Bars. This is enabled, by default. Disable it. Then the behavior will be the same, as Audio events. The MIDI event starts and ends at the place, when you hit Record/Stop.

Thank you!

I’m having the same issue, but that preference does nothing for me. When I press “Record” on a MIDI track, Cubase creates a MIDI event that goes all the way back to the start of the track. How can I turn this off?

Cubase Elements 10