Auto-scoll and mouse editing (SOLVED)

Hi,
if auto-scroll is activated, project is playing, I edit a note with mouse (or a container) and transporation bar reach the end of visible area, it scrolls to next display area, and the note is moved / stretch to the new position.

For instance I wanted to extend the length of a note for 1/8 more, and now it is multiple bars long due to display change.

A great addition would be to disable (temporarily) auto-scroll if a note / container is clicked / hold with mouse. And resume the auto-scroll when mouse is released. That would avoid any error of editing occuring while playing.

Thanks

Hi,

The Auto Scroll is disabled automatically, once you click and move the MIDI Note. Then the Auto-scroll is disabled until you enable it manually back (by the [F] Key Command).

From my point of view, it doesn’t make sense to enable the Auto Scroll automatically after. Because you would release the mouse (place the note somewhere) and the view would jump to other position immediately, so you wouldn’t have the visual feedback, where the MIDI Note ended up.

Hi Martin, thanks for responding. It does not auto disable here. :face_with_raised_eyebrow:

Hi,

Do you have the Suspend Auto-Scroll when Editing option enabled, please?

1 Like

Fantastic, that was the solution. Thank you.