Auto-scroll inconsistent

When I have auto-scroll enabled in both my main window and in the key editor, it doesn’t always follow. For example, if I have one midi region selected while the key editor is open, and then I select another region, the cursor is somewhere off-screen in the key editor. Even if the regions and their notes are essentially parallel. This doesn’t really make sense. It adds another click or even rewinding to the process. If auto-scroll is enabled, the open key editor should always jump to that point.

Why?

Everything is fine. Cursor is where you left it. Never had that feeling that something is wrong.

If you don’t like clicking the mouse, use L key to put cursor at the beginning of everything, notes or cips or whatever.

Also your way will make it harder to work with clone clips, you can edit in one place (at bar 134) but play bar 13. With your way cursour will jump to 134th bar even if I don’t want it.
I use static cursour for project and never follow it in MIDI editor. I press Shift+F to see the whole part.

Also I have just tried and I guess your way will break the way it works if you forget to disable follow in midi editor and open clip while the project is playing, if I understand you right, in this case the cursor will jump for where it is at the beginning of opened clip, what is wrong, don’t you think?

Get used to it, that’s it.

I think you’re misunderstanding…if my cursor is on bar 134, and I click on the violin region that goes from 130-140, the cursor is indeed at 134. However, in the key editor, the cursor is off screen and it’s showing like 128-130 for example. Or whatever the bar numbers are, the cursor is not visible in the key editor, despite the fact that follow is on. If follow is enabled, the cursor should always be visible in the key editor. That’s what follow means, correct?

If I then click on the bass drum region that goes from like 132-150, without moving the cursor, the key editor should still focus around the cursor as long as follow is enabled. Yet it does not. The focus is on some other place and the cursor is off screen.

No, follow means that screen follow cursor not cursor follows your watching area. Cursor lives its own life and not navigates the arrangement view, if you not make it.

Yeah, definitely misunderstanding. If follow means that the screen follows the cursor, then what I’m saying is correct. Until follow is disabled, both the arrangement window and the midi key editor should always be showing where the cursor is. But they don’t. If the cursor is at 134 and I select the violin region, the midi key editor should jump to where the cursor is at 134. If I then select the bass drum region, it also should jump to where the cursor is at 134. But it doesn’t.