Automatically Trim MIDI Track Event when recording stop.

Hello my friends:

When I am recording a MIDI Track and stop, I notice that the track event or clip can go on even if I am not playing anything.
Usually, after I have stopped, I will drag the event and trim until I get to the notes or where I actually stopped playing.

Is there a way to configure Cubase so that when recording is stopped the event is trim to only where notes were captured?


Preferences > Record > MIDI > Snap MIDI Parts to Bars. By default this is enabled. Disable it, please.

Thanks for the input.

I am using Cubase 10.5 and I unchecked this option but it does not work.

When I hit record, start and stop playing, the length of the event is wherever I hit stop not where I stopped recording playing


I see. Yes, Cubase works this way. There is no preferences.