Automation Bug Cubase 10.5 - confirmation and repeatable problem

I posted a problem I was having with automation (https://www.steinberg.net/forums/viewtopic.php?f=286&t=192709) , and also found another user’s very similar issue (https://www.steinberg.net/forums/viewtopic.php?f=286&t=165708)
I have managed to recreate the essence of the bug (Cubase not reading automation properly) very easily, following these steps:
All of this carried out in Cubase 10.5:

Please close Cubase and open a fresh instance - if you open a new project when Cubase has already been open and running, this bug doesn’t seem to happen.

  1. Create a new, empty project
  2. create 2 audio stereo tracks (default settings)
  3. create a group track (Group 1) and route the 2 audio tracks to Group 1
  4. Add the VST ‘TestGenerator’ to each audio track so that you have a signal (I just left it at the default settings)
  5. Adjust the volume faders on audio or group track for comfortable monitoring, I don’t think that affects the outcome.
  6. Open the ‘Mute’ automation track on Group 1 and draw a couple of On and Off commands a bar or two apart. Enable ‘R’ to read the automation if necessary.
  7. Press play just before the first ‘Mute’ command.
    Result = you should have something similar to my screenshot -

    It is clear from the cursor on the project screen that the Mute automation has turned Mute off at the point round 4.5 bars. You can also clearly see that the signal generator is sending a signal from both audio tracks to Group 1. Group 1 is unmuted - and yet no sound is audible and there is no meter activity.
    I set two further off/on commands on the automation line, and the audio does suddenly route properly after the second ‘On’ command is reached during playback.
    As per my instruction before point 1, this only seems reproducible if the new project is created from a fresh instance of Cubase. Loading up a second new project, automation seemed to work fine. Can others please confirm if they get the same results?

My System:
PC , Windows 10 Home Edition
Processor: Intel i5-6400 @ 2.70GHz
RAM: 8GB
64-bit
Audio Interface - Focusrite Scarlett 2i2 USB connected.
Cubase: v10.5 , upgraded from v7 a few weeks ago which was when I last checked for updates. I have never had this problem on Cubase v7 so do not believe it is a system problem.