Automation Gets Stuck in Write Position

Hi Martin, good to see you here. Automation was done by mouse.

I tried to reproduce the problem without success. It happens randomly


This issue appears time to time here on the forum (see this thread for example). But I haven’t able to reproduce it so far. And so far, I was under the impression, this happens with a hardware connected only.

Do we have the possibility to unite the different threads about this?
to collect more data…

Glad to see this issue getting some attention.

Wish I could reproduce it. So frustrating…

What’s odd is that this bug has been reported all the way back to Cubase 9, yet is not widespread enough to have gotten attention.

Here is a video of the bug in action, back on Cubase 9.5 (happens to me on 10 and 11 as well):

Write Automation Issue - Cubase 9.5 - YouTube

Martin, for what I can tell : the only hardware connected I do have is a midi keyboard. It is always connected (no setup change occured during my tests). I don’t use it to write automation, I enter it by mouse.

Which plugins are in use?
Is this happen with plugin parameters?

When the problem happened, it did it in any plugin I could try (FabFilter, KiloHearts). With the function “Bypass” (Cubase Bypass feature, not the internal plugin one)


My guess is, it must be some kind of timing issue. From my imagination, Cubase sends the Write Off information out, but some hardware (that was my original idea) sends the Write On (slightly) after.

I’m wondering that you can replicate this multiple times in line, when it happens. When does it stop then? Is it after loading the project again? Or restarting Cubase? Or restarting the computer? Or just randomly?

Hi Martin and thank you for investigating :slight_smile:
This also happens regularly on my side. I have hardware connected (a KK keyboard, an ipad and another tablet running Touch OSC). I’ve spend some time trying removing them all and adding them progressively but so far no luck.

The only thing I’m pretty sure at this point is that when the bug happens ONCE, it will happen on every new automation record after that, even with the disable/enable trick. Closing just the Cubase project doesn’t seem to fully reset the behavior, it seems like I have to close and restart the full Cubase application to go back to normal.

I’d be happy to make further tests if this can be of any help to track down the issue.

Same here. Similar setup to yours.

This bug seems to occur with any plugin, or put more simply, for any automatable parameter (pan, volume, channel strips, etc)

Just to add to data. This is completely random behaviour. Once it gets stuck it stays stuck. Enabling/Disabling instrument will clear it but obviously that doesn’t work for tracks that aren’t instruments.

I have added an android tablet recently for automation (faders etc) and it was working flawlessly. I’ve not seen the write stick when actually using the faders on the tablet. Always on mouse entered writes in real time. However, I removed my tablet and have run without it for the last few days thinking that might be the issue, but has happened twice without that device plugged in.

Only other device connected is my controller (Arturia Keylab 88 MkII)

Hope this helps.


This can also be used as DAW controller (via Mackie Control or HUI). Do you have set it up as the DAW controller, please?

Yes. Is it. Using Mackie. Uses MIDI IN and OUT 2. For clarity, have had this for a little over a year and not had any issues with stuck writes until a few weeks ago. There is nothing new installed with the exception of a couple of additional Spitfire Labs instruments.

As I use a Stream Deck and don’t really use the Transport control on the Keylab, do you want me to remove that profile and see if the issue goes away?

Ahhhh … actually. mentioning the StreamDeck has just reminded me of something I tried a month or so ago. I installed Cubase plugin for the stream deck that featured controls for the StreamDeck for Cubase. It also reads the state of Cubase BUT only if you install a MIDI loopback plugin. It didn’t really help much so I ended up getting rid of it and going back to my “handmade” profile (which was basically just sending key combos to trigger what I had set up in Key Commands).

The loop back channels were deleted as part of the uninstall and they are no longer available in Studio Setup.

I’ll hunt down the loop back software I used and report back in case this helps.

Ok the utility is called loopMIDI → loopMIDI | Tobias Erichsen … but as I say it’s no longer installed.


So there was the case of 2 DAW controllers again (when you were using your Android tablet and Keylab). But it’s not the case anymore. But you are still using at least one hardware DAW controller. Am I right?

Yes correct.

LoopMIDI here as well!