Auv3wrapper

curious about the auv3wrapper, but there is no cmakelists and files seem to be missing from the iOS project in the latest sdk dl. Is it not ready i noticed it said (preview) somewhere

happy holidays

oli

Hi Oli.

So you are still here!

I also tried to compile the AUv3 and interApp samples. For iOS I get nothing to work, although I remember it did last year (at least interApp).

The only thing that works for me is the AUv3 for macOS as stand-alone. But for that I had to make some changes in the CMakelists.

You have to set the cmake parameter SMTG_IOS_DEVELOPMENT_TEAM to an actual team ID you get from Apple when you have a paid account, otherwise the iOS AUv3 examples are not included in the project.

macOS Auv3 build doesn’t work in Logic for me, no GUI, but that may be a logic problem.

Hey Oli, which macOS version and which Logic version? And what about Garageband? I only tested in Garageband and there the editors always have shown for me.

I just tried again in Logic 10.6.1 on macOS 10.15 and 10.14/ logic 10.5 and it worked there. On macOS 11/ Logic 10.6.1 arm it doesn’t show the UI

same in garageband

Yeah. Looks like Big Sur broke this. I filed a bug at Apple.