Avid Support Asks: What is WL's dependency on CFnd.dll?

So the most current version of Wavelab crashes on my system when exiting the application but also occasionally during use. The culprit is Avid’s CFnd.dll file. I’ve opened a ticket with Avid who has confirmed the issue but they are asking me to reach out to Steinberg to find out what Wavelab’s dependency is for an Avid file.

PG???


PT 12.7.1
Win7/64
WL 9.0.35 (642)

WaveLab does not know this file and does not use it. It is maybe loaded automatically because this is part of an ASIO driver. You should send a crash log to Avid so that they study why their module is crashing.

http://duc.avid.com/showthread.php?t=271417

orangeoctane, I just wondered, do you still have Quicktime installed on the Windows computer? Probably nothing at all to do with your problem (although it’s mentioned in the cfnd.dll link above), but I uninstalled Quicktime on Windows computers when Thomas Bethel mentioned a warning from Homeland Security to do so a while back. Possibly something to try if you haven’t already, although I think he initially had some cd burners disappear after QT uninstall. I didn’t have any issues.

I do have QT installed. I’ll remove it to see if that changes anything.

Avid replies:
CFnd.dll is not part of the ASIO driver so it’s still not clear why the library is loaded when WaveLab launches (it’s actually a component of Pro Tools (full name “Core Foundation”) which handles OS abstraction and file I/O).

PG?

You should ask PT what this CFnd.dll is about.
What I can see, is that it is used in many PT files (there is a reference to this CFnd.dll when I do a binary search across the PT folder).
This means, many PT component could be at the origin of the problem.
If this is not an ASIO driver, what could it be?
WaveLab will not look into the PT folder, unless this is declared (by you), as a VST plugin path.

We have seen this before. And also with the opposite: Cfnd.dll was not found (which can cause PT not to want to launch).

FWIW, our spin on this is that PT likes to take control of all drives (that it can see). If PT is left open, or not quit (properly) the PT session will still control the drives. This in turn can conflict with WL (and other apps).

This, of course, is a “feature” of PT and nothing to do with WL … even if we are “wrong” with our theory.

Have the same issue.
I have a crashdump-file at almost every exit of Wavelab. Only when I open and immediately close wavelab there is no crashdump.
It is not just with Pro9 but with 8.5 too. Did not test with 32-Bit Version yet.
When I remove the CFnd.dll from the ProTools location no crashdump is created any more. When I try to start ProTools I get a message about import is not possible and ProTools will not start.
I have trashed all the Wavelab Preferences but the problem is still showing.
Looked into registry but could not find any issue - all the entries in the registry pointing towards the CFnd.dll seems to be linked with ProTools.

No idea where the problem is comming from.

PG do you have any clue?

Just to let you know.
I did now the test with Wavelab 9 Pro - 32 Bit and no Crashdump-file.
Even so there is now another CFnd.dll at Programs (x86)\Avid\Pro Tools.
Maybe someone has an idea what the rootcause of this problme is.

Try this (just a possibility to try)
Take any file and rename it as “no_newheap.txt” (the file contents has no importance, only the name has)
Then put it inside this folder:
C:\Program Files\Steinberg\WaveLab 9
I also assume you use WaveLab 9.1

Launch WaveLab. Does it help?

Hello PG,
thanks for your assistance.
Yes I am using Wavelab Pro 9.1.0.
I tried you hints, but unfortunately it hasn’t solved the problem.

Here is the XML-View of the Event Viewer

1000 2 100 0x80000000000000 36412 Application HomePC - WaveLab9_1_64.exe 9.1.0.684 5940da94 CFnd.dll 12.8.1.921 5996715b c0000005 00000000003eacda 1120 01d32463ff42f832 C:\Program Files\Steinberg\WaveLab 9\WaveLab9_1_64.exe C:\Program Files\Avid\Pro Tools\CFnd.dll 020e77ef-8d2a-4938-a813-f3ae5c774389

You should try to find with Avid support, at which occasion this CFnd.dll is used. For sure, WaveLab does not load it explicitly, it completely ignores its existence. It must be loaded indirectly, or injected by some service.
Please ask Avid about what this file is for, and which modules use it.

An idea: maybe this dll is loaded by some plugins you are using. Keep an eye on that.

It’s not any of the plugins. I can merely open Wavelab with nothing loaded and it crashes 100% of the time when I close it. Avid said “they are still working on it” as of 2 days ago.

orangeoctane … if you start the computer and (before launching ProTools) launch WaveLab before doing anything else: does WaveLab still crash?

Or, does WaveLab crash only after ProTools has been launched once.

Have you got quicktime installed? It seems your windows install is broken a windows reset might help
https://makemusic.zendesk.com/hc/en-us/articles/115006031968-Pro-Tools-12-Finale-v25-crash-Windows-

Finale has the same problem, there it’s due to an AVID audiodevice

It crashes before launching Pro Tools.

Another interesting thing I discovered is that killing my internet connection also causes this same exact crash with CFnd.dll being the culprit.

Hi there.
I am only a guest: a user who encountered a similar issue with ProTools and Cakewalk by Bandlab.
The Cakewalk friends in the forum directed me to this thread which seems to be unsolved.
With their expertise - and not with help from AVID, I am afraid to say - I could get rid of the issue and hope what I will relay here might eventually help you here to solve your issue.

Thanks for your posts, Cakewalk friend, brillant.
I shall put that all in the thread I have with AVID.
Of course I can try out renaming that digiasio.dll, first I’d have to see the properties:
Years ago, when PtoTools was made by Digidesign, I had an LE version which I abandoned (Cakewalk Sonar was way better then!) but never deinstalled from my PC.
I turned back to PT as alternative DAW when there was the “Gibson Crash” and it was unclear what youd happen to Cakewalk after that. At that time of course I deinstalled the old PT version. But I am not sure if I did that only after installing the new PT version and some how what dll “survived” on my PC. I’ll check that tonight…
If that dll is older than2 years, I will even try to delete it, start PT, and if that works, I will shred it from my bin.
Sure I will tell here, and there.
Thankx again.

(in the evening…)
Searching my PC for that file digiasio.dll, I found 2 of them with identical name but different ages (one of 2015, the other one from April 2018), and in different locations.
I deleted the older one and first tried to open ProTools, and a session there. No problem encountered.
Now I opened Cakewalk, NOT as admin, - - - NO PROBLEMS ANYMORE! Yay!
But I shall watch this…

So maybe I am not the only one with that “installation history”, although such a search might take some time, for PCs: I found the bad one at
C:\Windows\SysWOW64, , no idea about Macs: please try by yourselves. This bad one I will shred now from my bin. Rest in pieces.

Update: this issue has been resolved with PT 2018.4 on Windows 10

When I had that issue, there was “PT 2018.7 ultimate”.