Avoidance issue

The selected slur in the picture actually goes from the E to the next E and not the G#.
I assume that this is a collision avoidance issue but I don’t think that that should happen here. I can manaully move it of course but could this possibly be fixed in some upcoming release? Or am I wrong about this and there is some other reason for this behavior?

Thanks, Bob.

The accidental is causing it and it seems to be a bug. If you move the accidental (or the note) 1/8 (or even 7/100) space to the right the slur will adjust.

this might also be a horizontal spacing issue, as in there is not enough room for Dorico to properly space the slur.
I tried it in an empty measure of one of my pieces, and it worked perfectly by default, without moving anything. I just entered the notes as is:

Tried just now on iPad and the misplacing happens only in Galley view, as soon as I switch on Page view it show the right position of the slur.

(p.s. I hope that’s not a violin part?!?)

Hi Bob, maybe you narrowed the Note Spacing in Layout Options…try to increase it a little bit and should work.
Edit: or increase only the value for short notes…


Like others have said, you can give the notes a litle more space., or you can activate the “avoid collisions” property of the slur and leave it unselected.
(I guess it is a guitar part by the way)
avoiding collision of a slur

Thanks all, I think I got it. Not a bug but rather a self inflicted problem
BTW, it is a Clarinet part.

I get the same “error” with only one bar, left aligned.