Awesome Cubase 12 cpu performance

I think I’ve been one of the most repetitive guys in this forum about the performance of cubase on mac. I was ready to sell my intel i9 laptop to buy a new m1, but I’ve just installed cubase 12, just opened a pair of projects, and I’m absolutely amazed. Projects where my cpu was reaching it’s maximum and it didn’t let me insert a single vst more, now I see with cubase 12 the cpu meter is around half of it. Hope this keeps on and it doesn’t suddenly start failing again.

For the time being, my biggest congratulations to the Steinberg team (hats off).

4 Likes

I was also under the impression that the performance was much better than 11 Pro.

One of the demo projects with more than 70 tracks + VSTi’s and around 160 FX is just flying on my Ryzen 3600.

Hats off :tophat:

2 Likes

Are you guys on a Mac or pc?

New update…

Taking a couple of projects to it’s maximum, full load of plugins (almost the majority of them in the mixbus and master channels) , now cubase 11, surprisingly, seems to perform a little bit better. Where 12 stops playing, cubase 11 still plays it even though it does it with some drop outs.

I have no … idea of what could happen yesterday when I tested 12 for the first time, but now I realise it was just an illusion and nothing has changed in the cpu management aspect in Cubase.

I withdraw my compliments.

That’s strange.
I tested again and what made a big difference was ASIO-Guard. Turning it on or off doesn’t yield the same performance hit.
I’m not working with very big projects generally, but I still don’t know what to think about ASIO-Guard.
Should it better be deactivated for tracking and re-enabled for mixing or should I leave it on all the time?

On 11 I always have audio drop-outs when loading a new project and playing it for the first time, no matter the size.
From the second time on it plays fine (a buffer thing?) …

A screenshot of my screen. You can see my cpu is around 10% of usage and Cubase Asio-Guard meter is full. A mess.

I’m on W10 Pro, Roland Octa-Capture @128 Samples buffer size. This is the “Pop Demo Austin Hull MIXED” with 79 tracks, around 160 FX (plenty of Reverbs), & 21 VSTi’s:

Id recommend to always set it to “ON”. I just noticed, that on C12 its setting from LOW to HIGH is a bit messed up. Definitely better performance on LOW now, whereas before it was better on HIGH.

1 Like

Amazing performance increase for me at least!

I mistakenly opened a project with a 256 buffer that I had to run on 2048 buffer on Cubase 11 - and it performed even better than earlier! :star_struck:

Go figure. :thinking:

It seems I need some major help as my CPU peaks with just one synth plugin active. Ive just returned to Cubase after about 15-20 years away from it as my original DAW was calling me :slight_smile: but Im freaking with this issue. I was about to get an M2 MacBook Air or pro but I realise something isn’t set right some where.

Ive spent the past few weeks browsing the DAW getting to know it again and creating my project template so its only this week I chucked a midi file on Knifonium by Knif just to have a quick listen and the cpu overload was instant. I managed to get a minute with it today via a simple 4 bar event on loop and simple gritty preset but even that went to overload after I started tweaking some of the awesome controls on what is an awesome analogue style synth.

Im fairly new on the forum of course and would really welcome the wealth of experience I have seen on here, coming my way. Your help will be greatly appreciated.

spec =
MacBook Pro (16-inch, 2019) 2.3 GHz 8-Core Intel Core i9.
CleanMyMac installed and the laptop is clean as a whistle and working optimally.

Project set to 96 / 24 but no other audio processing levels are set/changed if there are any that should be. I noted the Asio Latency levels seem very high.

I have a fair amount of plugins on the inserts of 4 buss, 3 vocal and the stereo output channels but all bar the Isotope Replay utility tool are not activated and bypassed just to make sure. 6- 8 instrument tracks are installed but also not activated (Inc. Kontakt 7, Maschine, Battery, Reaktor 6, Knifonium and Thorn.

A few suggestions:

  • Unless you have a compelling reason to use a sample rate of 96 kHz, I’d suggest lowering it to, say, 48 kHz, that should ease CPU load
  • Disable all unused instrument tracks
  • Disable (not just bypass) unused plugins
  • Make sure your buffer size isn’t too short (what is it set at?)

Thanks Tim

By not active I meant disabled in the case of all plugins. Have changed to 48 and that’s vastly improved the situation.

Buffer size -
where do I find this so I can set it as I have suspected it needs attention. Struggling and searching buffer in the HELP search doesn’t recognise it

Best

Mark
+447930 427 517

I should have stressed that it’s still not great albeit vastly improved. I can use the synth now for example but it drops out as it’s playing across the event.

I suspect buffer size will be the next vast improvement. Hopefully the end of the problems too.

I still have all the instances of Replay active as first mentioned.

So I found where to change buffer size and it was set to 256 so i changed to 512 for now.

AUDIO SYSTEM
I also realised that using my internal audio card was part of the problem so now connected to my Scarlett 6i6.

Before and after, input and output latency levels = Before 27.8 / 22.9 and now 13.9 / 13.6 respectively. Asio guard unchanged at 32. If i set asio guard to HIGH it goes up to 106. NORMAL 32 and LOW 21.

I notice that if I deactivate ACTIVE MULTI PROCESSING (in ADVANCED OPTIONS), Asio guard latency drops to 0. Presumably I should have multi processing active and the latency is 0 because I’ve removed that audio processing path?

Are there any other crucial settings to get done as part of my project template? I dont know if i’m missing a trick. sure i"ll work it out through trial and error otherwise.

I feel really stupid for not factoring the lack of external audio interface, connection. Studio is almost finished so I’ll be connecting up the hardware in a few days, if i can get the project template in full working condition.

Thanks again Tim

1 Like

Glad you got things working better!

I did not change any of the Cubase audio processing default settings on my system (aside from dialing in my buffer size to have latencies similar to yours), and the system runs very well, so I don’t have any further recommendations at this point.

i shall give it a good run properly asap and see where i stand.

I noted i did have a few effects only bypassed after all. I thought I’d turned them off, but some slipped through. all off now.I have channel latency on my channel strips just above Notes and below the racks and it was interesting to note which of those effects that were on were creating latency on individual channels once bypass was off. Tails by Unfiltered Audio created a 100ms latency and their granular reverb Silo was 30ms. Nectar was 1ms, All others didn’t record any latency. I haven’t as yet learnt what these details mean for an overall project’s performance but to create an option to have these per track latency totals in view and so prominently I suspect they matter in some way.

Anyhow, much appreciated assistance Tim. Take care

Unfiltered Audio plug-ins and Nektar can demand quite a bit of CPU, so unless you need them, they’re prime candidates to turn off altogether (not just bypass) to prevent audio glitches.

Yes I came to that conclusion

Best

Mark
+447930 427 517