Awful/ unusable video performance

I have just imported a 1080 H.264 .mov file into a so far pretty lightweight project. 6 - 7 tracks of EW Play and some HALion tracks.

And the performance is awful. Unusable. It plays for about 3 seconds, then a stutter turns into a freeze.
No audio glitches. Increasing latency doesn’t help.

The funny thing is, I can run MPC or another program playing the exact same video file SMOOTHLY while CUbase is playing back my project. This is exasperating!

(Some specs: i7 920 (1st gen), 16 gb ram, Nvidia GT740. Steinberg UR28M Latest Cubase Pro 9.5, latest HALion, latest EW Play)


Maybe Nvidia is the problem. Try to upgrade to the latest Nvidia driver. If it doesn’t help, try to downgrade to 373.06 driver, please.

No, didn’t help.

And, as I said, I can play the same video file when Cubase is running, and it plays with no issues whatever. So my computer’s performance is not the issue here. Rather Cubase/ Cubase’s video engine.

It play smoothly for about two seconds, then freezes, and doesn’t unfreeze until I hit pause.

What video codec do you use, and where (what application) was the video made?

I spent quite a few hours trying to find the one codec/container that works best, looks best, and has the least strain on CPU.
For Cubase Pro 9.5, I have a dedicated Decklink Video-Card that outputs video to a seperate monitor. Sometimes it just works. But if the video-file has a weird format & has to be decompressed, I notice quite a few lags, no matter how big the session is otherwise.

I now use ffmpeg to prepare video for Cubase. In my case, the best format for video is MJPEG in a .mov container. (.mp4 works, too, but then Cubase has trouble rendering thumbnails, found this in another thread…)

This is my command, which I place in a .bat file in a dedicated folder, also in this folder are 2 subfolders “render” and “newfiles”. All files in “render” will be converted

for %%a in ("render\*.*") do ffmpeg -i "%%a" -vcodec mjpeg -q:v 1 -ar 48000 "newfiles\"

-q:v 1 is very high quality, you can lower it to lower file size (1 is best, 31 worst).
-ar 48000 i like to force samplerate to 48khz, (my session default)

I now have smooth video in C9.5 & thumbnails show up fast. This should work fine if you use onscreen video from Cubase, but haven’t checked.

So happy I took the time to understand ffmpeg, its the fastest and easiest. also for audio, theres no better way to convert samplerate on 100s of audio files, or extract audio from video…

btw. For my ableton sessions I have to use xmedia recode, which is a good program, too. there’s a h264-setting, the only one that works for ableton, which for some reason has it’s own video problems on PC.