AXR4T stopped working after latest Big Sur driver release - Solved


I have installed the latest drivers released for Big Sur (which worked for a couple of days) and today I saw that the AXR4T is not functioning. I tried to uninstall the drivers, and I have also installed the latest Universal Audio UAD drivers and just to make sure also uninstalled them. The AX4T Yamaha Thunderbolt control panel does not see the AXR4T. I have also tried to install the older drivers and still it does not work.

There are 2 possibilities: Either the AX4T hardware has a problem (which I doubt) or that something happened to the Mac OS uppon installing the latest Big Sur drivers. I do not want to freshly install the OS just to be able to know.

Any help would be appreciated,

Are you possibly able to roll back using time machine?

Hi Steve, thanks for the help.

Something very funky is happening uppon installing the new drivers. I was able after 2 hours of uninstalling and reinstalling to get 1.1 drivers working pre reboot. Once I boot, the AXR4T is not recognized again. This is not a hardware fault. Pure software based, and I think the cause is the new drivers that even uppon uninstalling still remain - my assumption is that is has to do with the System Extensions.

I don’t have an AXR4T here to be able to offer any further help other than if you were able to roll back using time machine as this would solve the mac side of things. If the update also included a firmware update then that would be more problematic. If a firmware update was part of the update then maybe a reset to factory settings might help

Heads Up to anyone who also encountered this type of problem.
I’ve managed to get the system running again by safe booting in Big Sur and uninstalling v1.1 (pre latest). Then booting normally and installing again. Everything got back to normal. Now I’m contemplating on installing the latest driver again.

You have to go to System Prefs/Security and Privacy/General. tab, unlock that screen with your password. There should be something there on that page asking you to ALLOW the driver to work with the OS. This option is ONLY there for 30 mins after you install the drivers.

Thanks shanabit - of course, I have enabled it and rebooted - it doesnt help.

Sorry man. Thats odd

After being tempted to install the latest drivers again, again things are not working and now I cannot even revert back.

Just an update in order to help other people here:
I upgraded in place the system to Monterey, reinstalled the drivers and viola - all is working. I am positive this has to do with the system extensions in Big Sur and the interaction of it with the new driver release. I hope at some point in time this will help someone. :).


thanks very much for that update. it’ll help me as I get my M1 Mac Mini this week…was a bit nervous about how things would go.

This may be linked to the security features linked to the T2 security chip which are set on by default in the Mac. In Big Sur OS I recall there was some information about security changes introduced in that version linked to the Macs with in built security T2 chip.

You can switch these security features off via choices available when booting into the Macs firmware setup mode.

You can discover if your machine has the T2 chip in Apple about this Mac system report / hardware / controller.

Lots of info in Apple support pages on the chip and its features.

I have Big Sur and AXR4T and recently upgraded to the latest driver with as yet no perceived problems but at the point of install I did have the T2 features turned off.


1 Like

Hello Dave, thanks.

Well, this might be the case for M1 related systems, but I’m using a Mac Pro Intel based which does not have to my knowledge the T2 chip. In any case, I have come across this Big Sur bug when installing UAD drivers and at the time called support which had to intervene - I could not have solved it otherwise. This same tyoe of bug I think occurred with the AX4T drivers and the only solution for me was to install Monterey OS on top - afterwhich installing the new drivers worked like a charm.

Very much enjoying the AX4 I think it’s a top notch product in terms of sound quality.


Hi David
I’m using my AXR4T on an Intel based 2020 iMac which has the T2 chip which switched off primarily due to a requirement to enabling booting my machine from external media. My setup also had a few driver extensions in use which I did not want to be effected or dump so turning off the T2 processing was my best option.
I love the AXR4T having upgraded from the MR816 CSX primarily due to using Thunderbolt cabling as my studio backbone.

I am however not fully comfortable yet with the AXR4 matrix routing, never feel I have a clear understanding of routing issue, which frustrates me no end.

I really need a some clear testing strategy for bugs occurring on both software and audio routings as software upgrades can affect several area with introduced bugs.

I tend to trust the manufacturer and alway try to upgrade to latest drivers and os where possible, but have become very wary on the Mac given the changes occurring from Catalina to Big Sur which changed many things like the file systems and security and the Apple intention to move to M1.

I use lots of differing audio software so Monterey upgrade is delayed for me plus I feel as I’m getting older I’m struggling to keep up to speed with all the changes in trying to keep my hardware and software stable. I’m assuming all the discussion about Big Sur drivers was simply about whether the AXR4 communicated with the OS at all rather than more specific individual bugs affecting parts of the system. As mine appears to be communicating ok I discounted any thunderbolt driver issues, however if the driver bug effects only parts of the commication ie digital and not analogue the error may not be so readily apparent.

As we seem to have similar setups feel free to contact me if you want to compare notes.

I’m trying to debug an issue on my digital routing at the moment and need a way of testing my axr4t digital inputs are working any pointers you can offer appreciated.

I have digital b enabled with an AES breakout so 4 in 4 out stereo pairs. I have looped one of those Aes7/8 connecting its ins to out but whilst I can monitor the output on the Aes7/8 in headphones I cant see any input going to the aes.7/8 input it’s directly connected to. I’m using the axr4t dspMixFx meter panel as the software signal monitor check so it seems it could be a hardware fault or
a software metering fault or the highly probable user error in understanding.

Do you use the AES digital outputs capability of your AXR4T?

Thanks David

Dave - Thanks. I sent you a private message.

David Bendayan