Back to 8.0.40


It’s really sad, but I’m back to 8.0.40 on Maverick.
Too much crash happened with 9.0.1 on Sierra.

Those crash happened for “nothing”… no plugin involved just saving or save as or import key command or quit…
Just cubase with retrologue, groove agent se4 and couple of audio track.

That’s sad… : (

I’m sorry you’ve had this experience. There might be something you need to do on your system, because 9.0.1 on Sierra is working great for many of us on Mac (aside from GUI issues for quite a few). It rarely ever crashes for me, even with gigantic sessions.

I don’t mean this in an insulting way at all: Have you tried contacting support?

Yes I contact support. Didn’t have answer yet.
I would have love to use Cubase 9 but I need to work and it was not possible.

I understand. I hope they get back to you soon, that must be incredibly frustrating to not be able to use it.

Suggestion: it’s Sierra, I suggest trying it with El Capitan

I managed to crash Cubase 7 - 8 times in a few hours after upgrading to Sierra … I’m back on El Capitan. This would happen with my most stable plugins which have never EEVVVEERR crashed once (u-he HIVE for example).

Cubase 9 and Sierra don’t go well at all in my experience, that includes Cubase 8.5 too.

This is wild because it’s rock solid for me on Sierra, with gigantic sessions and plugins from almost everyone you can imagine (though because it’s still not on the same level CPU-use-wise as some other DAWs it can’t handle as big a session as PT or Reaper).

On some systems it seems to be an issue. I wonder what the underlying problem is for those who are experiencing problems on Sierra?


Share some of the Crashlogs via PM with me, please.


I just erased my disc and start fresh with Sierra, re-install Cubase 9 and all plugins.
Seem to work fine now

No problemo, will send them shortly