Backup interval question

Around noon-time today I started a project, RitmoEwe01, and I’ve been working on it sporadically all afternoon. It created a .BAK file early on in that process (13:10 in the attached image) but that’s the last one it made. This project has grown considerably since earlier today. Normally my projects have a succession of .BAK files.

I was manually doing Saves during part of that time but when I noticed that it wasn’t automatically making .any more .BAK files I stopped manually saving for a couple of hour-long segments but it still didn’t make any more .BAK files.

My Auto Save Interval is set to 25 minutes, as can be seen in the attached image.

Is there something else I need to do to enable automatic backup files?

Thanks in advance.

My understanding is that Cubase will not run the save option if you are either playing or recording at the moment when it is due to do so. There also need to have been changes to the project file since the last save.
That it doesn’t appear to just wait until you’ve stopped playing/recording and then save is annoying to say the least.

I was making frequent changes and edits during that whole period (as can be seen in the big increase in file size between the .BAK file at the beginning and the last manual save) and most of the time was spent editing, not playing. I don’t do any recording. So it’s still not clear why there were not any more auto-saves happening.

Cubase has a complicated UI and I’m a noob so I want to make sure there’s not some other setting that would override the auto-save options shown here in Preferences.

I can’t think of any other setting you’ve missed. That’s how I have it set up and it works as far as I can tell, I know about the not saving when playing or recording so regularly do my own saves when I remember…which isn’t what you want to hear I’m sure.
Hopefully someone else will come up with something else to try.