Bad staff spacing of single-line percussion instruments

When I’m creating parts, my single-line percussion instruments are a mess. Is there something I’m doing wrong? What’s the best way to remedy this?
Thank you!

Hi. Difficult to answer without seeing the whole file… It seems Dorico is forced to cramp stuff vertically. I find there’s a problem with your dynamics on bar 63 (mp and p at the same rhythmic place), and of course, bar 100, where the 7 (rehearsal mark) is, it takes a lot of room vertically. There are settings you could change, and you could also make sure there are not breaks (make sure Signposts are visible), and that Layout options>Vertical spacing>Ideal gaps>Gaps between systems is at least at 9 spaces.

1 Like

Ah I figured it out and it has nothing to do with single-line instruments. It seems the cause was that my page was over 100% full, and seemingly-random bad things just start to happen then. I’m really just learning how to use Engrave Mode, but my new policy is if anything looks strange in the layout, instead of spending a lot of time trying to figure it out, just bump a line or 2 to the next page and 99% of the time all of the problems go away.

I do wonder why a default part with no changes would allow fullness over 100% instead of just pushing things to the next page? Is there a setting…?

And by the way, @MarcLarcher, having both mp and p on that bass drum roll is crucial to my artistic expression, ok? :wink:
No, of course that’s my mistake but that spot does also point out Dorico’s occasional unfortunate habit of not making space for a hairpin, like the one that belongs between the p and the ff. Anybody know a good way to keep that from happening?

Yes, that’s the quickest and easiest solution. The reason Dorico overfills the page is: It makes a guess as to how many systems will fit based on settings, then does collision avoidance. It does not go back and recalculate the fit, because that would slow the program down too much. (This has been explained much better by Daniel elsewhere several times.)

1 Like

Put fewer measures on that line so the notes spread out more and leave room for the hairpin.


Dorico should be able to avoid the situation where the hairpin ends up too short to be visible on its own, but doesn’t always do so. This is something that’s still on our backlog for further work.

In the above case you might want to disable automatic collision avoidance in Layout Options. This will space systems evenly regardless of any attached markings. You can then move a system or specific markings individually to avoid overlap.