Bar Numbers and Rehearsal Marks

Hello, I am having an issue with some bar numbering interfering with my rehearsal marks. I searched through some previous forum posts, but given that what I could find is going on 8 years old, I figured I would just write a new post and hope something more recent has come about.
I am using bar numbers as my rehearsal marks, and I would like to have bar numbers appear in every measure centered on the barlines at the top of my score, except for those measures in which there is a rehearsal mark. As far as I can tell, I have all of the correct settings in Layout Options (mainly the option “Show bar numbers at rehearsal marks” is turned off). With all that said, I am having both the rehearsal mark and the bar number showing, both when the rehearsal mark is at the beginning of a system or part way through.
Funnily enough, the parts’ layouts do not have this issue. The bar numbers are hidden at the rehearsal marks as they should be. I thought that maybe this was because the bar numbers in my parts are set to show every system instead of every bar. If I set the score to show every system, I still have this issue. If I set the parts to show every bar, it still works properly.
Is there a setting that I might be missing to have my score acting this way? It’s only in the score. I know I could manually go in and hide the extra bar numbers in Engrave Mode, but I would like to avoid that, especially since this is a larger project and that would be a very time consuming process. Any and all help is greatly appreciated!

This is working for me. If “Show bar numbers at rehearsal marks” is already off – with your score layout selected on the right – you may need to post a cut-down project in order for us to determine what’s going on. (You can delete the music.)

Just a thought… are you perhaps seeing the bar numbers displayed because you are in Galley View?

I am in Page View. I only use Galley View when I am working with multiple instruments on the same player.

BlankVersion.dorico (907.1 KB)
Here is a file upload. I deleted all of the music, title, etc. I’ve kept all rehearsal marks, tempi, key and time changes, and formatting settings.

Thanks for the file. The problem is now well-illustrated! Unfortunately I don’t have a solution. Maybe Daniel or someone can figure out what’s happening.

Hi @roseph.josen the culprit seems to be the layout option Show rehearsal marks below bottom staff. Deactivating it gives the normal behaviour for the deactivated option Show bar numbers at rehearsal marks.

Just to be sure: opening your file I see the system track activated (the bar numbers there, are only an overlay and are not be printed, just in case you think these are the real bar numbers), and I see these settings:


and

The settings that works are:

and

@dspreadbury It is indeed strange that activating Show rehearsal marks below bottom staff seems to influence/annul the expected non-appearance of bar numbers in the presence of Rehearsals marks, (despite the correct settings for the bar numbers to not show at rehearsal marks ) only for the upper staff (the bottom staff, with both bar numbers and rehearsal marks, acts as expected). Or did I miss something?
A similar problem has already been mentioned here.

1 Like