Bar Numbers/Reh marks

Unless I’m doing something wrong, checking “Hide bar numbers at rehearsal marks” in Layout Options:Bar Numbers doesn’t appear to work.

Am I missing something?

Lew,

Does this happen at the beginning of systems?

If so, see Daniel’s explanation:

https://www.steinberg.net/forums/viewtopic.php?f=246&t=105953&p=605129#p605129

It happens everywhere (see attachment.) I’ve also attached a screenie of the settings.

Thanks


Dorico will only hide the bar numbers when they coincide with rehearsal marks if they’re likely to actually collide, e.g. if they’re on the same side of the staff. There’s no way to influence this behaviour, except perhaps to manually create a bar number change at every bar at which a rehearsal mark is present, and then activate the ‘Hide bar number’ property in the Properties panel, but I really wouldn’t advise this.

Daniel, if you have time, could you explain why you wouldn’t advise this. Also, I noticed that I don’t have to create a bar number change in order to hide it using the properties menu. I can simply select the bar number and hide it. Could this cause problems in some way?

Thanks.

The only reason I wouldn’t advise it is because you’ll be creating a lot of bar number changes for very little gain. Is it really a huge problem that you will see the bar number both below the staff at the margin and above the staff to the right of the clef? Would it not look more inconsistent for a bar number not to appear in its usual place at the start of the system just because there happens to be a rehearsal mark there?

Yes, I see, a lot of busy work… Good to know that would be the worst of it and not damage the file or anything scary like that!

My own thought on this is that yes, I agree with you that it looks good to my eyes to have both Rehearsal Marks (as bar numbers) and bar numbers that are placed below the staff. But I don’t like the look of Rehearsal Marks (as bar numbers) and bar numbers that are placed above the staff, because it looks duplicitous as they are next to each other.

By the way, I am not seeing bar numbers appear at system breaks when the “hide bar numbers at Rehearsal Marks” is enabled anymore. Has this been changed? I remember they used to appear. No need to respond…

Thanks for your clarification in the previous post Daniel!