Barline interaction: stop before doesn't work with grace notes

If I have a grace note in an instrument on the downbeat, the hairpins in another instruments never stop before the barline (i.e. without crossing it) when they end at the end of a measure. This happens even if I set not to do so in the properties panel. Is this expected?

hairpins grace (378 KB)

It’s nothing to do with instrument it is, it’s to do with the fact you’ve got gracenotes at the start of the bar that are adding space before the downbeat. Increase this setting if you’re not happy with the current result:

I thought this could be the cause, but even if I set an absurdly high value like 100, they still cross the barline. Besides, if I set an override in the properties panel, why does it keep happening?

Now turn OFF the override in the properties panel. I don’t know why it works the way it does, but that’s how it works.

Intriguingly, if you use the global option in Engraving Options > Dynamics > Gradual Dynamics > Advanced Options > Hairpins ending at beginning of note at start of bar, you don’t run into this problem at all.

Thank you pianoleo! This worked. Still, it looks odd to me that the override property doesn’t work in this case, but for now it solved the issue without having to tweak in Engrave mode.

Any insight on this same issue but when it occurs at a system break? Fiddling with the settings mentioned here, nor the setting regarding “Continuation hairpin at system break” have any effect. Current settings below:


I’ve attached a snippet of the project where this is occurring.
Piano redux.dorico (667.2 KB)

I think your only option here is to leave the fortissimo dynamic at the start of the new bar, and edit the duration of the hairpin such that it stops at the final note of the preceding bar, and adjust its offset in Engrave mode.