Basic Audio CD Settings - CD too long?

I’ve just mastered a jazz CD that is 1h 15m 52s in length. When “checking CD conformity” I receive the following error:

“The CD is too long (according to what is set in the CD Settings dialog).”

So, I am trying to adjust this by returning to the Basic Audio CD settings, but don’t find any parameters to adust.
I’m assuming it’s too long? Can’t a Red Book CD be 80 minutes?

In the main preferences, CD burning tab, you can redefine the maximum length of a CD. By default, this is 74 min.

Thank you!