Batch Metadata Merge Issue

I can’t get the batch metadata Merge function to work. The source wav file has RIFF and ID3v2. Using Inherit in the file format, metadata Merge selected, outputting MP3. I fill in the batch metadata section manually with ID3v1 fixed info (not variables), and ReplayGain checked. But the final MP3 file only contains the metadata inherited from the original WAV file. Am I doing something wrong? On Windows 7. WL 8.5.30.

Also the ReplayGain won’t stay checked unless other info is also entered in the batch metadata.

Merging is more than just selection the option in the batch processor.
Did you read the dedicated chapter to know the ins and outs?

My reading from the manual means to me that it should work with the options I’ve selected given the source I’m supplying: inherited, merge, addl data added to batch metadata, should equal result with both inherited and batch metadata. But there’s only inherited in the result.

From the manual:
Batch meta-data
Lets you select one of the following options for handling the batch meta-data:
• Ignore the batch meta-data and preserve the meta-data in the audio file.
• Merge the batch meta-data with the meta-data found in the audio file.
• Replace the meta-data of the audio file with the batch meta-data.
These options only have effect if Inherit from source file is activated in the Audio File Format dialog.

This is difficult to see clearly without a case. If you have an audio file + batch files to send me, I could have a look.

Thanks PG. I found another section in the manual that seems to explain what’s going on:

Meta-Data in the Batch Processors Workspace
You can batch process meta-data. For this you can set up the Meta-data dialog in the Batch Processors workspace, and apply the meta-data to the files of the batch process.
In the Batch Processors workspace, on the Format tab, the following options are available:
Select Ignore if you do not want the batch meta-data to change the meta-data of the files in the batch.
Select Merge if you want to merge the meta-data of the batch with the meta-data of the source files (WAV files only).
Select Replace if you want to replace the meta-data of the source files with the meta-data of the batch.

When it says “WAV files only” for Merge, apparently that means the Output files have to be WAV for Merge to work. I was finally able to get ReplayGain merged with Inherited when coming from WAV, going to WAV.

It makes it less useful than if it could Merge to other formats, like MP3, but I guess that’s the way it is. And I guess ID3v1 can’t be Merged at all because it’s for MP3 only.

But it turns out I can only get the ReplayGain merge to work in 8.0.4. I can’t get it to work in 8.5.30. Can anyone reproduce?

I tried this on Mac and get the same problem with Merge. It works in 8.0.4. It doesn’t work in 8.5.30.

To reproduce in batch:

  1. use a WAV file with metadata (like the BWF UMID factory preset) as source file.
  2. set file format as factory default, set batch metadata as merge.
  3. in the batch metadata, check the replaygain checkbox.

The result file in 8.0.4 will have the replaygain merged with the inherited metadata.
The result file in 8.5.30 will only have the inherited metadata (no replaygain).

I will check this soon. I just have many things to do right now.

Confirmed. Ouch.

Daved, even when it’s fixed I can’t imagine it’s ideal for anybody’s workflow if it will only merge to WAV (not MP3 or any other format). That means multiple intermediate WAV files, and multiple steps in multi-format batches.

Wavelab really needs to support metadata interchange between all formats in WAV ALAC AIF FLAC AAC, and metadata merge from and to all.

Wavelab batch has many more other possible advantages, but in this department (all file format read and write capability and metadata exchange), the free programs already have it beat.