Batch processing multiple formats by pressing " Run all " wont work correctly in W11

Hello there,

I’m at the point that getting bold from scratching my head is a understatement :slight_smile:
I’m having some problems batch processing several items in one go using the " Run all " option.
Pressing the " start " button meaning one process after another seems to work fine.

i have several pre-sets loaded up for exporting my preferred formats, for example
Tab 1: CD output format
Tab 2: Mp3
Tab3: 2444 and so on .

Now pressing " start" on each individual tab works like it should.
However pressing "run all " which should do it sequentially does not. ( i noticed marking the checkbox " stop on error " gives some inside: it says " This file is already being processed ) in some cases.
resulting in skipping the tasks, leaving them with a Red circle ( resetting the files status and start over often does works)
Obviously its supposed to do it in a sequence so i can get a coffee or 4 while doing its thing.

I already checked and double checked all my pre made output presets for anomaly’s but there’s nothing different in the one 's that do or don’t get rendered .

So here we are with me being bold with no coffee breaks :wink: sad face.

Anyone that’s havening some tips on this ?
thanks !

The “Run All” command executes batch processors one by one, but not in any specific order. Hence, if one batch processor depends on the output of another, then you are likely to encounter a problem.
Could that explain your case?

Hi PG1,

No not really, they do not depend on each other.
They are all separate outputs, just like you would do for lets say output to 16bit/44.1 Khz
and one for like 24bit /44.1
its nothing special really.

and works fine if i activate the batch tabs one for one so there’s no issue there.
however having multiple pre-sets tabs open ready to batch process wont work .
it randomly does for instant the first one, skips the next process one and so on.
Wavelab also gets stuck sometimes and i have to Ctrl alt del to stop the entire process in windows management.
its only when i use the Run all option. which is kind of the whole point if I’m not mistaken.
Run all open tabs with the options and preferences i made a preset for.

So for Cd it outputs a 16bit-44.1 file in a folder that i setup the way i like.
same for lets say a Mp3 file. nothing fancy really.

is that making any sense ?

I did a quick test and could not reproduce it. If you send me your batch processor files (no audio), I could try to reproduce.

What kind of audio files are you using as inputs?

Hi PG,

Thanks for the reply the input is a rendered audio file from the montage in 64bit - 96Khz
attached is text file with a link to my files.

Link to (329 Bytes)


The link leads to a web page that goes around in circles.
I send you in a PM an alternative.

Should be in your mailbox.

Thanks again

I have tested your 7 batch processors with the “Run All” command. Each batch was set with 20 files 96k / 64-bit. Each file’s set in a different folder. Hence 140 different files in total.
I had success in running all this.

The only thing: I have removed the Izotope plugin from one batch since I don’t have it.

Hence, unless the Izotope plugins cause the problem, I have no clue. I have used WaveLab 11.2 which will be available this week, but I doubt this makes a difference.

Thanks for trying PG!

The Ozone plug isn’t part of the issue for sure.
I tried with several different settings multiple times before I posted my initial message on the forum.

It’s a strange one really, will try and reinstall Wavelab tomorrow morning, Maybe that helps.
Can also send you a short video ( screen capture ) to show you what’s happening when I press “ run all”
Something is going wrong but I really can’t seem to figure out what it is.

Anyways, thanks again for your help.

Please do so, and in that case, the video should show the audio file lists.
Use the URL I gave you. I

Thanks, this is useful. This is definitely a WaveLab issue, even if I still can’t reproduce it. I note this to my todo-fix list. But since the next minor update is closed and about to be released this week, I am afraid I won’t be able to provide a solution soon.

No worries PG,

Thanks for your time! hopefully you find the issue in the near future, until then i will do them one for one. ( Btw just checked if it would make a difference if i start Wavelab as administrator.
Unfortunately it did not.
Thanks again PG! please keep me posted.


A last question: the source file that is mentioned in the error message, is it also inserted in some of the other batch processors?

Yes, in this case its copied from clip board on all .

I think this could be a timing issue, then. The source file is not yet “closed,” and WaveLab tries to open it for the next process, hence the error message. Maybe your computer is too fast :wink:
This gives me some hints, thanks.

1 Like

I’m not surprised if its related to something with multicore processing.
i did already tried to use just one core to see if the outcome was any different, it wasn’t.
Can be many things obviously, wish i knew :slight_smile: