beam angle issue


I need to lower down a cross staff beam in engrave mode, but I can’t get the result I want to achieve.
When I lower the first beam, the staff spacing is enlarging and the beam angle is imposed (picture 2).
From there, I can’t make it flat at all…

Am I missing something obvious here ?

All the best
Screenshot 2020-05-20 at 16.20.25.jpg
Screenshot 2020-05-20 at 16.20.19.jpg

Can you attach a minimal example, e.g. just those bars, so that we can take a look? Pictures unfortunately don’t really allow us to get to the bottom of the issue, but even a minimal project with all but the affected bars deleted helps us immensely to be able to help you, as described in this sticky thread.

Ok, here you go Daniel

Measure 1, first beat.
This is an example of what I’m describing.
When I switch to Engrave to bring the beam lower, it redraws the beam angled and increases the lower staff distance.
I have other places doing a similar thing.

Yan (715 KB)

Thanks, I can see what’s happening here. I think there is a small bug here in the new feature to start and end beams with rests – this works correctly if you use stemlets, but not if you don’t. We’ll take care of this as soon as we can. Sorry for the inconvenience in the meantime.

In the meantime, what appears to be happening is that when you drag the beam down, the last beamed note’s “End Y offset” is correctly set, but the first note (or rather rest)'s “Start Y offset” isn’t being set. You can set it manually, though.

Oh I see, thank you Daniel.

Pianoleo, thanks for the tip; took me a while to find that “Start Y offset” because of the new local/global setting.

Thanks !