beam group question -- stemlets and extending over rests

Hi all,

My habit with beam groups with 16ths and smaller is to have the beam group extend over rests unless the group begins or ends with a rest. So with four sixteenths in one beat, for rest-note-rest-note, I’d have the last three 16ths beamed, and a stemlet down to the second rest. For note-rest-note-rest, the first three 16ths would be beamed, and a stemlet down to the first rest. And I don’t do this for groups of eighths, just 16ths and smaller.

With Dorico, unless I’m missing something, stemlets are possible only if the whole beat is beamed. And stemlets force full-beat beaming for 8ths also.

In Finale, I achieve this in the Document options, checking “Extend secondary beams over rests” and “Display half-stems for beamed rests,” and not checking “Extend beams over rests.” I also check “allow rests to float.”

In Finale, the stemlets are consistently one size. In Dorico, the stemlets can be VERY long. And once stemlets are used, no longer have full control over the beam within that beat group.

I think my way of doing things is not unusual. The closest I can get with Dorico is to keep stemlets off – but I want the stemlets, and I want them of a consistent length (because the rests float), and I want them NOT to force the beam to cover an initiating or terminal rest in a beam group.

Any ideas?

Thanks,
David

Is this what you’re trying to achieve?
Skjermbilde 2017-07-05 kl. 22.25.41.png
I don’t know if there’s a way to do it automatically.
But you can easily do it manually by using Edit -> Beaming -> Stemlets -> Force stemlet beam.
You can assign a key command to this function if you use it a lot.
The ‘Allow rests within beams, maintain secondary beams’ option in Notation options -> Beam grouping will take you one step closer.

If I may pop in, I’ve noticed you can’t start or end a group with a stemlet. Is this correct, or am I doing something wrong?

Notation options -> Beam grouping -> ‘Use stemlets’ should give you this, right?

Thanks, Anders. That looks exactly like what I want to do. The key stroke and the beam setting sounds like the way to go.

Daniel,
I was experimenting with this topic, and noticed a strange behavior:

Using ‘Split beam’ on the 2nd beat does nothing but resetting the beaming of the 3rd beat. Is this a bug?

Anders,
That’s what I was experiencing when I wrote that the stemlets forced full-beat beaming.
I’ll fool around with this and see if I can get it to work. My workaround is not to use stemlets…
David

If I “Allow rests within beams, maintain secondary beams’ option in Notation options” and then force stemlets where I want them only (by selecting the rests), I get what I want. The only exception is in piano cross-staff writing, where the stems extend quite far down to the rests in the lower staff. I don’t like the look of the very long stemlets, but don’t seem to be able to control that.

You should be able to change the length of any individual stemlet via the Properties panel.

GREAT!! Thanks!

Daniel, actually selecting the stemlet does not bring up any properties, nor can I get a property to adjust by selecting any combination of things for the beat. It does give a box to grab and drag at the end of the stemlet, but that doesn’t want to go anywhere. I drag it up or down, and it pops back to its original setting.
David

There’s a little bug here: you need to select the rest and set the ‘Force position and duration’ property before you can set the stemlet length. This shouldn’t be necessary (setting the stemlet length should automatically set the ‘Force position and duration’ property).

Thanks, Daniel, that works!

By the way, the advice not to include an initiating or concluding rest under a beam comes from the Schirmer style manual.

It should, and I’ve tried reproducing my problem in another project and I can’t reproduce the behaviour in a new project, so never mind.

Hi - I too have noticed that the stemless in Dorico can be quite long.
Stemlet Dorico.png
Here is the way they look in Finale.
Stemlet Finale.jpg
It would be great to be able to customize this globally, rather than having to adjust each individual stemlet. Do you folks at Dorico see this being possible at some point?

Try changing ‘Gap between outside of rest and inner stemlet end’ in the Stems section of the Notes page of Engraving Options.

Brilliant! Thank you!