Beam groupings for sycopations

I’m in 4/4 and have set beam grouping to beam to the beat. Why isn’t this displaying accordingly?

image

Pretty sure it’s this setting that dictates this:

1 Like