Beaming over rests

It’s not a bug, but rather a limitation in how the beam grouping code works with rests within beamed groups at present. This is on our list of things to improve, hopefully soon, though probably not, I’m afraid, in time for the next update.

I’m running into the same problem, with Dorico 2.1.10.1080. Is this still a limitation in the program, or is there now a setting that overcomes it that I haven’t found yet? Thanks!

There hasn’t been any change in this area recently.

Is there a workaround?

You can use the stemlets option, and adjust the stemlet lengths in Engrave mode so they are invisible.

Tedious to do, but it depends how badly you want to do it!
beams.png

Thanks, Rob. It’s tedious to do in Finale as well, but essential to be able to do it in Dorico. Can the rests be moved down into normal position?

Select the rests and set the “rest position” property.

Thanks, pianoleo. I’ll try it when I do my next Dorico demo.

As promised, I am back finishing up my Dorico 3 demo and got to what is shown in the following example using the previous suggestions, but how does one adjust the length of the beam stub?
Dorico beaming.jpeg
And is there now a beaming option in Dorico 3 to avoid the unwanted beam break?

Not practially, really. The partial beam will draw to the appointed horizontal position as determined by the stem whose length you have reduced to nothing.

Really I think the only practical solution here is to wait until we have had a chance to revisit this area of the application and make some changes. I know we have not yet had a chance to do so, but I will try to push it up the priority list.

Thank you very much, Daniel. Yes, it would be good to prioritize this one.

(ignore)

In the very specific situation that this thread is about, no, you can’t.

I just stumbled upon this problem, and I thought there was a (working) workaround. I think we really need a solution for this! The stemlet workaround makes everything so ugly, especially for some rhythmic patterns that don’t have the problem that requires the workaround. Is it possible to invoke the stemlets in a granular way?

You can certainly force a stemlet for an individual note or rest; the rest must be an explicit one for this to work.

Thank you so much for your answer, dear Daniel. I had not thought about using the context menu for this (I was looking at the properties panel, but with no luck). I happened to find that it works well, even on non explicit rests (but then I need to turn off the automatic beam splitting in the properties panel). With the shortcuts provided thanks to Notation Express, changing 20 rests was quite fast. I hope my client will be satisfied with the result (the third rhythmic stem is a little too long, but it’s better than the default).


Capture d’écran 2020-02-27 à 20.20.32.png

“But I stand by my prediction that sometime in the next decade a GUI notational product will be able to notate this simple rhythm without a workaround. I’ll bet it is Dorico.” (John Ruggero)

Congratulations to the Dorico team for solving THE problem in the 3.5 update!

We have in fact been working on this specific problem over the last couple of weeks.

It’s wonderful to see that we will likely have a solution to the “Dvorak Humoreske/Grieg Piano Concerto” conundrum. However, I did devise a convoluted but better looking workaround that I shared with a user once. Here a copy of the exchange:

Michele. It turns out that I found something of a workaround for this, although I would only use it if I had to create a flow with one or two examples of this “Dvorak Humoreske” beaming. Any more than that and it becomes a cumbersome task. However, in the interest of sharing, here is what I found.

Instead of the 32nd rest, write a note, preferable the same as the 32nd note.
Remove stem and ledger lines trough the properties panel
In another voices, add four 32nd rest using force duration starting on the last quarter note of the bar. (move the caret there, type 3, o, comma, and then y four times in the new voice)
Hide the rests you don’t need
Flip the stems
Move the rest position through the properties panel

Now, in a lot of cases, using the “correct” rest (the third one) as the visible rest will result in the 32nd note flag to be a bit long (as the first bar of my example). What can be done to change this is use the 2nd 32nd rest as the visible one, and move the 3rd rest (or invisible note) closer to the next note using the note spacing tool. I realize this may not be up to engraving standards and of course it would be grand to have that beaming option natively. I do hope it comes reasonably soon, but in the meantime, I thought I would share it. It looks like this:
4EDEA578-B703-4717-B4B8-CDE03B382B7D.jpeg

Great news!