Been using 7 for a while, then suddenly have a delay...

I have been working on some music after i installed 7, and it has been working perfect. then suddenly, i get a delay or latency on everything i input… guitar, keyboard… whatever. driving me nuts, it worked just fine 2 days ago, then suddenly it is useless. any ideas? pretty sure i didn’t change anything. would love some help before my head explodes!

First of all, get an umbrella so your brains don’t get on the ceiling. It’s easy to clean th efloor and walls, but the ceiling is hard to reach.

This must be related to a change in your asio settings, either audio buffer, asio guard on-off etc.

That’s all I can say since there’s no info about your system in your post.

not sure what to add… i haven’t changed the buffer size but i will go look and post it. I am running cubase 7 (have not added the beta update) on my mac. it is the latest of everything, intel quad core etc… still the current production i believe. let me go look now…

i am using a Focusrite pro40, i have the ASIO driver set to it as always. It reads Input latency - 8.798 ms, output at 8.798 ms, Asio Guard latency 11.610 ms, HW rate 44.1, HW Pull up/down - off

audio prority (normal)
multi Processing (Checked)
ASIO-Guard (checked)
2-secon preload
Adjust for record latency (Checked…

Saffire Control panel / coreaudio device settings

buffer size 256
set device attenuation checked


does that help? like i said, it has been working perfect until suddenly… at this point, my head could actually explode, my wife will not be happy

And you already restarted the mac, and power cycled the focusrite pro 40?

I don’t know. I would turn off asio guard and change buffer settings to see what’s up, and I would update to 7.0.1.

i have turned off everything and back on multiple times. I will try turning off the ASIO-Guard. I havent updated since it stated that it was a beta. I will do the update anyway, and hope for the best and report back. thanks.

Sorry I can’t be of more help.

If it continues you should probably follow the troubleshooting step of moving the Cubase 7 prefs out of the prefs folder temporarily to see if this is simply corrupted prefs files. Also move earlier Cubase files out too for good measure.

It’s in ~/Library/Preferences/

You can just hit shift-g in the Finder paste that into the Go to Folder dialog.

okay… just realized something… i started a new project to test it and there is no latency or delay. It seams to only be in the existing project that i was working on. both virtual instruments and trying to record a guitar through the pro40 inputs give me a delay… works fine on a new project if i start one. any ideas? what is it about an individual or specific project that would give a delay?still could be a corrupted file of some sort?

what is it about an individual or specific project that would give a delay?

A plugin with a high inherent plugin delay for example…

wouldnt that only affect the channel that the plugin is associated with? and not the entire project?

No.

i turned all effects on all channels off and it has no affect on the delay…

If you want to really test it, you have to remove the suspect plugins. Switching them off may still maintain the delay.

Seconded. This happens to me a lot with certain UAD plugs. For example, putting the ATR-102 on the master buss adds a ridiculous amount of delay (60ms) to all audio coming into Cubase via live inputs (e.g., my hardware synthesizers playing MIDI parts) BUT NOT TO ANY PARTS GENERATED INTERNALLY (software synths, recorded audio tracks).

You most likely added a high-latency plugin to your mix without realizing it has high latency.

okay, i can try that. I am only using plugins that came with cubase 7. i have not added any third party plugins but i will give it a try anyway. thanks, i will post the results. I really want to get back working on this song, if i cant figure it out soon i guess i can export all the tracks and start a new project.

I have to say I got weird problems with fast audio with 7 (my audio interface would default to 48)–including saying that my audio hardware was not compatible with 44.1 16 bits, then I upgraded to the beta and it’s all fine. I’d just try it.

‘Thirded’.

For me it is multiband processors.

Impossible to track a MIDI guitar if a MBProcessor is loaded.

I try to track everything with as few FX as possible.

HTH
{’-’}

‘Fourthed.’ You are spot on. Happens to me with the UAD Precision Multiband, too. Adds at least 50ms delay so all live audio goes out of sync.

Wow, you guys are awesome! i removed the Cubase ‘Multiband compressor’ from the ‘stereo output’ channel that i had added for whatever reason and the latency went away. I guess i learned something important here today. I didn’t realize that adding the compressor must have been done right after my last recordings were added instead of earlier. So basically, i should add these effects at mixdown time after all my recording has been complete? i assume that is a big yes.

I didnt know that they would add a latency to the input when i added it to the output…

They don´t add latency to the input, they add delay to the complete signal path (full Plugin delay compensation, unless constrained) and since obviously, you listen via the Cubase output, any signal has to go through it.

Ehm, I would say No: Add any processing on the main stereo out in a separate process called ‘mastering’. :sunglasses: But okay, that’s perhaps a bit purist in these necks of the woods… Thinkingcap does bring up something else you may want to try: ‘Constrain Delay Compensation’: see the description in the manual.