Beginner Needs Help Setting Up to do Drum Covers

I’m an absolute beginner and not a “techie” - using Cubase Elements 10.5 as my DAW (on a PC) and Focusrite Scarlett 18i20 as my audio interface. I have the Shure PGA Drum Kit 7 setup for mics. So far almost nothing about this process is intuitive for me. I have read “The Complete Guide to Music Technology Using CUBASE 10.5” which was informative but not the step by step assistance I was looking for. As mentioned in the subject line, I wish to make drum covers using my acoustic kit with mics. I would import the song I wish to cover as an MP3 file and add my drums. Does anyone have experience setting up in CUBASE for this purpose? And would you be willing to walk me through the process?

Hi and welcome,

  • Open Studio > Audio Connections > Inputs.
  • Click to Add Bus and add 8 Mono Buses.
  • Set the Device Port to your Focusrite Inputs 1-8.
  • You can even double-click to the Bus Name to rename it. So if you know your Kick is Input 1, you can rename the Bus.
  • Close the window.
  • Import the MP3 file.
  • Add 8 Audio Mono tracks. (You can double-click to the track name to rename it.)
  • For every single Audio track, set the Input in the Inspecotr’s 1st tab.
  • Choose Mono In 1, Mono In 2, etc., or if you name the busses, choose the name of the input.
  • Every single Audio Mono track has to have unique input.
  • Enable Record on all Audio Mono tracks, you have created.
  • Hit Record on the Transport panel.

Thanks so much Martin. Couple of questions:

  • Once I set up the inputs, is the OUTPUT “Stereo” and Device Ports “Output 1 and Output 2”?
  • Do I need to set up any inputs/outputs for the MP3 file? Right now I have it as “Stereo IN” and “NOT CONNECTED” to Audio Device
  • How do I play this MP3 track while recording on the other tracks? Last night I was trying to play the MP3 and record my kick drum, but couldn’t get
    the MP3 file to play while I was in record mode.
  • How do I align the click track to the MP3 song’s beat? Another thing I was trying to do last night without success.
  • Once I get the inputs squared away, should I create a Group Track for them? If so, how do I configure that track’s input?

Just a quick follow-up on my earlier questions. I’ve figured out the top 3 items, please disregard. Still not sure about getting the click track to sync with the MP3 song It starts out okay but it loses time within a few bars. I’ve read some stuff about needing to realign this but I wasn’t sure if that applies to an imported (professionally produced) song? I think I’ve set the tempo in Cubase correctly. I changed the tempo showing on the project window to the correct tempo. But this made no difference with the sync. I’d like to be able to play to the click track while I record to help me keep time.

And then still curious to know if there is a benefit to creating a Group Track for the drum tracks. And if so, how should that track be configured?

Again, thanks.


Yes it does apply. The reason is, every single device has its own clock, which is always a bit different. Therefore 120BPM on machine A is not the same as 120BPM on machine B. You have to create the tempo map from the MP3/WAV file in Cubase: Project > Tempo Detection.

Yes, there is definitely a benefit, but not really in your use case. When you are recording a common (whole) band, the benefit is, you can mix your drum sounds independently. Then you can use the Group Channel to mix the whole drum (battery) against the rest of the band. So If you want to lower the drums volume, you don’t have to lower all 8 (or more) channels. Only the Group.

Got it! Thanks again!!

Hello Martin,
I am stuck once again. When I select the MP3 track in my project window, then go to Project, there is nothing there that says Tempo Detection. I see Tempo Track, but when I click on that I only get another blank slate, which I don’t know what to do with.

Thank you.

Tempo Detection feature is not available in Elements, only Cubase Pro I believe.

It’s a bit easier to alter the project tempo/grid to match the imported guide audio on Pro, cos you can use the tempo detection feature to make a tempo map.

With Elements it will be a bit of a faff, but it can be done by ear+eye… There may well be an easier way, but the following should work:

With a Tempo Track activated you can use the pen tool to insert tempo change points, + you can manpulate these points to make the grid match up with the tempo in the guide audio. One way to do this would be to put a tempo point on the downbeat of bar 1 in the tempo track,and drag the guide audio event so the bar 1 downbeat as seen in the waveform lines up with the tempo point. Then select the tempo point + use the mouse wheel to alter it’s value whilst keeping an eye on the grid, which will expand and contract relative to the waveform of your guide audio. When the grid line at, say, the beginning of bar 4 lines up with the downbeat of bar 4 in the audio waveform, you’re good. if the guide audio is not at a constant tempo then you’ll need to keep putting more tempo change events in and manipulate them so the barlines of the grid match the downbeats you can see in the waveform. As Martin mentioned, even if the guide audio was recorded with a click at a constant tempo there can be discrepancies caused by variations in clock speeds, etc.

After all this, playing + recording the drum parts will probably seem easy!

Thank Ian. I’ll give this a try.

Latest roadblocks if anyone can assist:

First, I decided to try another method of inputting the song I want to cover. Using a 3.5mm to 2-Male RCA Adapter Audio Stereo Cable with 1/4 inch adaptors, I recorded the song onto a track from my iTunes. It seemed to go in fine and played back with no issue. The next day, I played it again and now the sound keeps dropping out. What could be causing this to happen?

Second issue, after recording the song I moved it forward 2 bars so that I can add a 2-bar count-in. I was able to do this successfully when I had the song on the track as an MP3 file. However, now I cannot hear my metronome nor can I figure out how to insert the count-in or hear it play.
I am certain that the metronome is activated. Just can’t hear anything. Thoughts?

As a reminder, I am using Cubase Elements 10.5 and a Scarlett 18i20 interface. HP Envy 360 (laptop) Intel Core i7 - 12GB Memory w/Windows 10. All brand new and dedicated only to this purpose. Thanks!

Martin, I’ve never used the Tempo Detection function but would MajDrummer be able to send the mp3 to a user who has Cubase 10 Pro and ask him or her to perform the Tempo Detection, resave the file with a different name, and then send it back to MajDrummer? That way he would have the mp3 mapped to a set tempo where the metronome would stay in sync. I may be way out in left field with this suggestion :slight_smile:!

An update on my message from Oct. 24. I was able to make some progress but still haven’t completely solved my problem. I figured out that I have to go to Metronome Setup>Audio Click Outputs>Choose Track. Then if I solo or monitor the track, I can hear the metronome.

When I go to Metronome Setup I see that there are 3 options Click Options:
Click while recording
Click while playing
Click during count-in

HOWEVER, I am still having the following issues:

  • Either the metronome now plays through the whole song (and as previously discussed, the metronome beat falls off the beat of the song)
  • Or, if I choose “Click during count-in” and then try to solo or monitor the song I can no longer hear the clicks.

How do I set the metronome to JUST play the count-in?

Next, referring back to the first Roadblock mentioned on Oct. 24th - I started a New Project and re-recorded the song the same way. It played perfectly fine until I closed Cubase and re-opened it and tried to play the song. When I did this, the audio started dropping out like it did before.


Could you try in Cubase Safe Start Mode [Disable preferences], please?

Hi Martin,
I executed the Safe Start. Recorded the cover song once again; it played fine. Then I shut everything down and reopened in Safe Start mode. Song played fine once again. Does this mean I should permanently disable preferences? If so, can you provide instructions to properly do that?

Karen Johnson


Yes, it seems something gets wrong with your preferences.

From the very same dialog, you can just delete the preferences. That’s it.

Okay thanks!!!