Behringer ufx1204 driver issues cubase pro 10.5

Hi all, (elderly hopeless tech head so go easy eh:) … since having to reinstall windows 10 64 bit, my behringer ufx1204 will not record into cubase pro 10.5 … I’m sure it’s a driver issue, ( I’ve had these driver issues before with this mixer but not sure how I fixed it… probably a fluke!) I’ve tried ASIO4ALL without success…and reinstalled the behringer drivers but still nowt… I’m probably doing something really stupid… hope someone can help… I need to write the hit!

Could you post a screenshot of your Studio>Studio setup>Audio system pane ? If the driver is an ASIO one and has been installed correctly as administrator, it should appears as the driver used by Cubase in it…

Hi, thanks… I’ll take some pics later when I get home :+1:

I’ve tried switching drivers but still no luck…?

OK… IMO, you should keep the UFX1204 USB ASIO x64 driver as the one used by Cubase and deactivate the ASIO guard, at least, for now. This done, I’m going to ask you also a screenshor of your Studio>Audio Connections>Inputs pane (to check what audio busses you have already defined) and an added one for your Studio>Studio Setup>MIDI port Setup pane (to see what MIDI port(s) is/are available).

After this, few questions…

  • What have you tried to record, audio or MIDI sources (if the latter case, with an instrument track or VST rack instrument, which involves a pure MIDI one ?)
  • In any case, What have you as selected in your Input Routing area (either in the inspector or in the Routing rack of the MixConsole) ?
  • A last question before going further : when starting a record (with the Record Enable button activated) do you get either a MIDI part or an audio event as a result, and do you hear what you are recording ?

Enough for now, I think… :stuck_out_tongue:

EDIT - Just looked more closely at the UFX1204 : it’s an USB mixer with no MIDI connections, so, unless you have a separate MIDI interface unit that allows you to record MIDI data, dismiss all what I stated related to MIDI…

Hi, I’m recording audio only ( I’m pretty sure midi is working fine , showing midi in data coming directly from my keyboard) … I can see a very low level of audio input when using the ufx1204 drivers …none when using any other drivers ( I’m sure all levels and outputs are ok from the mixer ) I’m only using main stereo inputs /outputs in the audio connections window ( once I get it working properly I usually use all 12 inputs to record many channels simultaneously, the ufx1204 is great for this , when it works!) sorry I can send a pic at the moment, (I’m at work… not working lol) just wanted to reply and thank you for your help so far … btw I haven’t yet tried to record anything as there is no input signal , but I will see what happens when I activate the record mode as this may show that I’ve got something wrong with my routing.
I’ll get back to you as soon as I can. Thanks once again.

hi, heres a pic of the inputs , still no audio signal when I activate record enable button… any further help would be appreciated

OK… have you tried to add more busses ? As the unit is a 16 imputs x 4 outputs one, I guess that there are a lot that are missing. Here, I created busses for nearly all the inputs/outputs of my unit, excepting for the ones that I’m sure will not to use, and that doesn’t make a lot left.

So, a suggestion : try to add busses for ALL your inputs with the Add Bus button : if not possible, there is something wrong with your driver : be sure that it’s the right one, uninstall and install it again. After this, if you still can’t get anything. I guess that there are either added levels issues or mismatching connections somewhere.

I’m leaving for two days, so I won’t be able to check the forum until late monday. Hope you’ll find something in the meantime… :slightly_smiling_face:

I’ve tried adding more busses but still no luck… I’ve definitely had this issue previously, and I’m sure it is a driver problem, just can’t remember how I fixed it… I’m sure it’ll sort itself out eventually. Thanks once again for your help.

Are you sure you’re ok on the mixer’s side? Do you need to press something to “activate” the usb out? The mixer just outputs the whole LR mix to usb and not individual channels, right?

Also, what’s up with sample rate? Do you need to do something from the mixer? Or is it always 48K/24 bit? Do your project settings reflect this?

Okay - so I was looking through the Cubase forum and saw this, While I do not have a solution to this problem, I am hoping it is okay to butt in here - I have a Behringer UMC404 HD as an interface between a Casio WK-1800 (hey - don’t laugh - it puts out a midi signal!) but the midi signal does not get all the way to my laptop. I am receiving MIDI data from the keyboard into the Behringer but it does not seem to make it from there to the laptop. I have tried changing cables, using a Midiman 2x2, and have no joy. I think it must be a flag that needs setting in Cubase but do not know. Please pardon if I am out of line. this is just driving me bonkers!

Hi, no problem with you coming in on this topic … unfortunately I don’t think I can help specifically with your mixer… I don’t use midi that much, I prefer to record in audio (I’m a bit old school) occasionally I use midi, but my keyboard is directly plugged into my pc with USB… the signal shows up fine in Cubase… maybe a usb keyboard would help, before I had one it used a midi interface…. Sorry I can’t be of more help. Good luck

Hi, I’m pretty sure the mixer side is ok with audio outputs going out via usb ( I’ve tried every button on the mixer) I’m only using stereo outputs for now just to keep it simple…. I’m not sure if changing the sample rate will make a difference but I’ll give it a try… thanks for your help

Ok. Since everything else seems fine, these are the things I would check.

  • Double check input assignment of stereo track. (The mixer coming to the PC via USB, that is. It should be in agreement with what shows up in Audio Connections.)
  • Press the Control Panel button at the UFX1204 tab of Studio Setup > VST Audio System. Then fiddle with what comes up, maybe raise the buffer, or lower it.
  • If this does nothing and no signal shows in the stereo track when monitor is enabled, I’d try it with the ASIO4ALL driver too. (Pressing the Reset button towards the bottom for good measure)
  • If nothing came out of all this, I’d completely remove the drivers, both ASIO4ALL and Behringer’s driver and try again.

Good luck!