Behringer X-Touch - Cubase 10


I’m having trouble with the Behringer X-Touch.
I have set it up nicely and it mostly works but it freezes and lags while writing automation. I am currently mixing a song with 44 tracks and it does not allow me to write automation by using the faders. It begins to write it for a bar and then the X-touch becomes unresponsive. What’s crazy is that I have no problems writing it by mouse, the motorized faders follow immediately.

The X-Touch is connected via USB and it is set up as a Mackie controller. I am running Cubase 10 on Windows 7 64bit with an M-Audio Delta 1010LP.

I have also installed the latest firmware.

Any suggestions would be appreciated!

Thank you!!

Does it still lag if you set the MIDI Output to “not connected”?

1 Like

Thank you for the response!

Unfortunately, yes!!

Of course, when it’s set to ‘Not Connected’, the X-Touch does not communicate with Cubase.

However, I managed to write two full bars of automation after setting it back to X-Touch. :laughing:

And just to clarify: it does lag but the most severe problem is the X-Touch freezing!

I have just purchased the X touch Compact and the trouble i am getting is in MACKIE mode most of the functions are working but the plugins and EQ do not appear on my screen anyway. The promotional video says (Phil)" It works straight out of the box" Hmm it does in MC mode but i have set up the editor software as per the the 6 page manual and dumped it to Layer A & B but no success
Any ideas please or even a midi map for Cubase functions would be nice

1 Like

What do you mean that the plugins and EQ do not appear on your screen?

This guy has done some custom programming work, maybe you’ll find something useful in the video:

Hi thanks for your reply … When i press the push button VPOTs on the right hand side which are customised for EQ and Plugins as per the Behringer promotional video the graphic does not appear.
Hope this clarifies my problem…

I solved the problem on my own.

I was suspecting USB incompatibility and malfunction and I was right.

The moment I started operating the device via MIDI it became sharp like old-school analog devices. No lag, no automation problems, just pure creativity.

I am happy!

They don’t work for me either. I press the global button to open the selected track and then I set EQ and plugins by mouse.

The top right buttons do work though. You know, the ones that change the top knobs from panning to other functions.

There are definitely ways to customize the devices functions. However, I have not gotten into it yet. I just got the device like you and I have only mixed a couple of tunes with it. It is probably more customizable in midi mode; I believe there’s a menu for that in the ‘Studio’ panel of Cubase 10!

As for my problem, I managed to solve it by operating the device via MIDI. It works beautifully now!

Yes Apollo89 I’ve spent a few nights on it now i just go back to the MC mode and use the mouse… You say that you programmed yours with midi and it works fine? I tried to configure under Studio > Devices > general remote using the midi learn function. The manual is confusing as it shows under layer A midi configuration CC numbers and Note. The guy in the video is amazing he knows his stuff, i did download a program called midi view that showed me the note value even in MC mode when you press a button or fader ….hope this helps