Behringer X1832USB - installation with Cubase 11

Dear all,

I am currently getting familiar with Cubase Pro 11 as an absolute beginner. Setup with my Steinberg UR22C was successful. Now I want to get my Behringer X1832USB mixer to work as well.

  • I downloaded and installed the ASIO4ALL-driver directly from Behringer product homepage.
  • I selected “USB Audio CODEC” in Windows 10 audio settings as input/output device.
  • Test of audio input/output in Windows 10 audio settings was successful.
  • I selected ASIO4ALL-driver in Cubase Studio Settings.
  • In Cubase Audio Connections appears “HD 2nd output 1/2” for output and “at front panel (black) 1/2” for input. Seems strange to me, but I cannot change it (up to now).
  • In Cubase Studio Settings I found another menu (WDM Device List) where “Realtek(R) Audio” is selected. Seems to be my laptop. In this list I found an entry “TI PCM2902 USB CODEC” which sounds familiar.

But whatever I do, I can’t get a signal at Cubase in and out (checked VU-meter bottom right).

I would highly appreciate your support!

Best regards,

Cubae WDM Device List_1

Cubae WDM Device List_2

The X1832 has to be configured in asio4all for Cubase to see it. In your images, I don’t see the X18, so I presume that the problem is in asio4all.

What is this supposed to do? Is it even necessary? I think not.

Oh. I tought, it would be necessary to select the required audio device in Windows as well. Thank you!

I changed Windows settings regarding audio input/output back to onboard devices and tried to access ASIO4ALL settings to configure the X1832USB for Cubase. I don’t know how to get access to ASIO4ALL directly.

In Cubase I deactivated “Realtek(R) Audio” in WDM Device List and tried to activate something that seems to be my X1832USB, but I still get no signal (see attachment).

You mentioned the “X18”. Should it be in the WDM Device List?

You choose asio4all in Cubase and that’s as far as it goes with Cubase. The rest would be in asio4all. You say you can’t access it but I can see it in your screen shot. It should be on the bottom bar

Dear all,

thank you very much for kind advice! I think I got it, input and output from/to Cubase is working now.

All the best,