behringer xr18 ASIO trouble

I can’t seem to get the ASIO driver in the XR18 to work with Cubase. I’m using version 7.5 and I have the Berlinger selected in the devices section. While I was researching the problem I clicked on a you tube video and it started playing through the XR18 so I know that my computer and the Behringer are set up correctly. Is there a patch or update that addresses this problem? Thanks.

Do you have the latest firmware installed? Also a good idea to head over to behringer forums as there are lots of users who can help you out specific for your xr18!

Mine works as expected, though I recently experienced that the port where you connect your xr18 to matters, try to use a dedicated port for it.

maybe posting a screenshots of your asio setup window will help

I Have updated the Firmware and I will lick into the behringer forum. Thanks.

So I looked on the Behringer forums and I guess no one else is having this problem (because they are all using other software). It’s so frustrating. Everything looks correct and this is the third interface I have used with cubase so I know hot set them up. Also, when I clicked on a Youtube video to research the problem the audio came right through the XR18 and out the speakers no problem. when I opened cubase again nada. Then I switched the input output configuration to 2x2 I was able to hear some mixes from cubase but then it only sees two channels from the mixer. going on a week now. anybody?

Post some screenshots and add your equipment to your post or signature, this way we can help you better.

I know you said you know how to set it up, but just to make sure we’re on the same page:

  1. You selected the Behringer ASIO driver in device setup?
  2. You assigned your in and outputs to busses in the VST connections?
  3. You assigned your track inputs and master outputs to these busses?

The questions Strophoid asks are good to answer as these are the basic steps to do routing.

When still hearing nothing you’ll have configure the usb outputs with the air-x mixer app,
remember the XR18 isn’t a soundcard, it’s a digital mixer with a built-in soundcard.

OK here is one of the three screen shots. I have to post them one at a time. I’m thinking now that this has happened before, back when I was using a Persons 24.4.2 That time the cause was a Mac update. After a period of time Cubase released an update which fixed whatever disconnection problem had occurred. In January Mac had an update and there has yet to be a cubase update so the ASIO driver/ core audio situation is not resolved. I tried to revert to a previous version of my OS but I was unable to make that happen.

Screen shot #2. #3 is too big to upload.

Thanks for your help with this guys I really want to get back to recording and your suggestions are great. I have walked through the set up again and everything looks good, all the routing appears normal. The picture I couldn’t upload was a shot of the VST audio system that shows the XR18 has been selected as the ASIO driver. Here is one more tidbit. When I am in the settings screen for the MAC and I look and the sound preferences for input, there is a display underneath the selections and you can actually see audio coming into the computer from the XR18.

What I think matters is how your clock source is been configured, and second but nor less important, the routing in your x-air application of asio (USB Channels) channels, in the digital mixer of the xr18 the asio channels needs to be reconfigured as well in order to communicate with cubase. In this case you do not only need to concern about the cubase config but also the configuration of the XR18, they must be aligned carefully in means of channels (USB routing to physical channels on the xr18 channels)