Behringer Xtouch - Can't get it to work at all

I have read through many posts here about this controller but have found none addressing the problem I have.

The controller is connected to my PC via USB. I also have midi in/outs going in between the Behringer and my midi-sport (desperate for a solution, trying everything. I updated the firmware to 1.15 with a lovely program called Midi-Ox. After a lot of trial and error, I finally saw the X-touch appearing under Mackie Control in Device setup.

And that’s as far as it gets. I have watched youtube videos, done massive google searches and had a conversation with someone else who is successfully using it, but they’re using a Mac. I have booted, restarted cubase, changed my midi cables, removed them, changed my usb port, changed from MC to HUI and back again. I have drawn the line at reciting the alphabet backwards. My husband wants to return the unit to Behringer but I say there has to be a solution.

Edit to add more info:
If I select USB, and don’t have the two MIDI cables between Behringer and midisport, I don’t see X-touch in the device set up.
If I select USB, or if I select MIDI, and I have the MIDI cables in, I do see x-touch in the device set up.

So, what I’m saying is, I can only see x-touch if the midi cables are in, regardless of whether I select USB or MIDI. I’ll attach an image of what the midiport setup looks like with the midi cables in, and the Ifc set to MIDI.


I can certainly relate to your frustration. I recently purchased an Xtouch and had numerous adventures of my own. I’m only up and running because others helped me, so I’m happy to do what I can. It is, however, working for me now, the occasional glitch aside.

The first difference I notice between our setups is that you’re running Windows 10 and I’m on 7. I connect via USB and I see the XTouch as a device panel option in both MIDI in and out, and you don’t. So, the first thing to research would be whether or not there are known issues with USB MIDI devices in Windows 10.

That said, what I’m not sure of from your post is whether or not the XTouch works for you if you’re running via MIDI. There’s no advantage to running USB, so I’m thinking all that matters is figuring out what works and getting it set accordingly.

I should also note that there are two modes for the MCU, Cubase and Compatibility. I run in Cubase mode. Here’s what I’d try next.

Disconnect the USB cable, leave the MIDI cables connected. Set the XTouch to MIDI. Reboot the PC and cycle the power on the XTouch while rebooting. Now bring up Cubase and make sure the XTouch is set up as a Mackie Control device with the Cubase mode selected. Then go into the Device Setup and make sure your XTouch in / out is pointing to your MIDI cables (the MidiSport, I’m guessing).

With that done, open a Cubase project, and press play on the XTouch. Does it work? If so, start testing other functionality, but be advised that the buttons on the XTouch don’t necessarily map to what Cubase does. If you haven’t seen it already, there’s a template someone made on the Behringer forums that shows which button does what in a Cubase environment, e.g. the Marker button is actually Locate Left, etc.

Let me know your results, happy to help further if I can.

I removed the USB connection, put the midi cables back in, re-opened cubase, and as soon as I selected the midisport in outs, it worked!! The excitement of seeing that board light up and all the faders jumping around was almost too much. lol. Thank you so much for your help, Chris!

Happy to help, although we’re both indirectly thanking Hugh. He’s the guy who helped me get my other problems sorted. Here are a few other things you’ll want to know.

First, here’s the link to the overlay. I just printed it out as a cheat sheet until I memorized the buttons.
https://forum.music-group.com/showthread.php?9134-X-Touch-Overlay-for-Cubase&s=57b1f7e450a6207a37871268d35c4c71

If you use Cues in Cubase, here’s info on how to call them up versus the Sends.
https://forum.music-group.com/showthread.php?17081-Cubase-9-Sends-and-Cues&s=57b1f7e450a6207a37871268d35c4c71

Cubase won’t bring up the selected plugin like Logic does, and all their videos use Logic so that threw me for a while. It will, however, launch the plugin when you’re adding it.

Another Hugh tip was Ctrl+Alt+Shift + the Global View button will bring up ALL of the plugins for the selected channel. Ctrl+Shift + the Global View button closes them. So, you can press select on a channel and see or hide all its plugins. Not as elegant as individual plugin control, but still keeps you away from the mouse.

Here’s a discussion of the shift key, which kinda sorta works. See the last post in the thread.
https://forum.music-group.com/showthread.php?16996-Shift-key-in-Cubase&s=57b1f7e450a6207a37871268d35c4c71

I have my X-Touch mounted at about a 15 degree angle as the LCD screens are useless unless you view them pretty much straight on.

The control of plugin parameters is a huge help. That said, many plugin manufacturers use names that are longer than the 6 characters the XTouch can handle, and when truncated aren’t always helpful. What you need to do here is edit your plugins. Bring up each plugin and in the upper right hand corner, select the dropdown list. One entry is Remote Control Editor. Not only can you edit the names, but you can create / delete / reorder the pages to what best works for you. A tedious process, but the end result is worth it.

Once you get everything sorted and happy, having hardware control is sooo much better (at least to me) than mixing with the mouse. There’s some work involved, but you’ll really enjoy it once you’re set up.

Hope this helps!

I will certainly be using all the information you’ve given me, over the next few weeks, Chris, thanks for taking the time to put that together for me. And thank you Hugh, wherever you are :slight_smile:

Yes, tactile mixing is a welcome relief from using the mouse - I can’t imagine anyone thinking otherwise. And my X-touch is currently propped up on 5 strips of foam I found in my basement. I’m guessing it’s at about a 30 degree angle right now and I could probably make it higher…

I’m off to have fun after a gruelling weekend (it’s the other way around for so many others. Aren’t we lucky?)

Happy mixing!

OMG!! I took delivery of a X Touch and thought I’d purchased a totally dud. Thank you guys for pointing out that the USB connection just didn’t work at all and to try the MIDI connection which worked. I must say the function of the buttons having almost no relation to the effect they are meant to produce is almost a deal breaker. Thanks to some fine work by others I will try the suggested overlays.

Question: What happened to the CLICK button to activate the metronome? I have temporarily assigned it to F1 but has it moved to some other location? Can’t see any mention in the overlays shown.

Cheers all.

Martin.

Hi, Martin.

For what it’s worth, I ultimately ditched the X-touch and spent the extra money to buy an actual Mackie MCU.

Thanks to all the help above I did get the X-touch working. However, one of the deal breakers for me was the angle of the LCDs. They’re designed to look straight down at them and they become increasingly unreadable the more your angle varies from that.I ended up propping up the unit on a piece of foam at about a 30 degree angle, and it was still only marginally readable. Plus, it was just flaky to have to mount it that way.

The Mackie is about twice the price. It is nonetheless worth it in my estimation. It’s built like a tank rather than a cheap plastic feel, is stable, and in my particular case the fact that the LCDs are perpendicular to the control surface meant I could mount it flat next to my mixer and be able to clearly read them.

If money is a factor, you can make the X-Touch work and with all the caveats and tips from everyone above it will certainly get the job done. That said, the LCD angle was a big deal for me personally, and both the cheaper quality and the absolutely non-existent support from Behringer made me more than happy to put it in the “for sale” pile.

I’ll lose a couple hundred bucks selling it, and I’ve paid twice the price for an actual Mackie, but it’s altogether worth it. The pain in my wallet goes away quickly. The experience of working with substandard gear lives on forever.

Hi to all,
in case to be late here, there is a solution about the connection-/cascading-problem mentioned above:
i wrote this at
https://www.gearslutz.com/board/product-alerts-older-than-2-months/900680-namm-2014-behringer-x-touch-universal-control-surface-30.html
####################
hi there,
i´m glad to finally found this threat, so with the very different mentions and hints from you i was able to solve the problems and now give it back to the community:

We were testing the Behringer XTouch with 2 extenders: (24channels) for a small project-studio:
A = XTouch (firmware 1.15)
B = Extender 1 (firmware: control 1.18, fader 1.04)
C = Extender 2 (firmware: control 1.18, fader 1.04)
DAW: Cubase 9pro
OS: Windows 10 Prof.
on the desktop: C,B,A from left to right (cause i am righthanded)

#scenario 1: A + B
connected via USB-cascade in Mackie-Control mode
everything works fine:
16 fader plus 1 masterfader, select, mute, solo, transport, pan, plugin-control etc…
the colors of the scribble strips keeps white/blue, but the text shows in two lines all the parameter and the channel-names

great ! so we have a 16channel DAW-controller!

#scenario 2: A + B + C
variant 2a:
A + B + C connected via USB-cascade:
only A and B are working as under scenario 1.
C is recognized in Cubase under the same name as B (extender)
Problem: not sure how to configure it/ name it differently

variant 2b:
A + B connected via USB-cascade and C via LAN
to connect C via LAN we have to:
-on the extender C:
-choose Mackie-Control-Mode
-Mode as Slave, port 5004 (the PC is the Master)
-DHCP, waiting for connection…
-on the PC:
-install rtp-MIDI (from Tobias Erichsen | private stuff & software for audio, midi and more)
-start rtp-MIDI
-new session (name = the rtp-MIDI-session-name =hostname = PC)
-in directory add new the extender (with the taken IP from DHCP and port 5004)
-network-connection to C is established now
-in Cubase:
-add a new device Mackie Control
(name = the rtp-MIDI-session-name > see above) for both Midi-In and Midi-out
-note: all 3 controllers must run in Cubase-Mode, not in „compatibility“!
-restart Cubase after powering on all X-touches (Cubase does not recognize them bevor)
-open your project and sing halleluja:

all the tracks are mapped to the right touch faders and channels on all 3 Xtouches

tip: to ensure that the rtp-MIDI connection is even on after boot/reboot of the PC, this runs automatically as a service in windows background, so there is no need to put it into the windows-autostart-folder or else :wink:

tip: i guess this (2b) is almost the limit under Cubase: some DAW´s do not allow two or more controllers with the same name.

Very special thanks to Tobias Erichsen for his great job !!! you made my day (and the whole year)!
################################
variant 2c: connected via MIDI only
not tested yet, after 2b works
i guess, the USB-cascade will fail (see above)
################################
variant 2d: connected A,B and C via LAN
not tested yet, after 2b works
i guess, that Cubase will recognize all three with the same name (same as in 2a)
################################
hope this will help all the XTouch-lovers doing more with this fantastic hardware.
have fun and make more music
greetings
Marc