Best practice for top-note voicings in jazz?

I’d like to notate some top-note voicings in a piece (chord voicing up to the player, but the top note indicated…the link has a good example). Is there a best practice for this?

To add more…what I’m doing now, is writing the note I want, and a note about a 4th below, flipping the stems up, and then hiding the lower note head with engrave mode (thanks ver. 4.3!!!). Looks pretty good. The only down side is that a dotted quarter still shows its dot which I don’t know how to hide…

Unless there’s a better way, I’ll stick with this for now.

1 Like

Sounds good to me! You could also suppress playback of the lower notes.

I thought we were fussing over the rhythm dot being hidden along with the notehead. You’re saying the dot still shows for you?

The dot is still showing. Is that not normal?
image

I’ve just added a quick and dirty graphic to demonstrate. This clearly isn’t exactly what I’m trying to do, but shows the hidden note head with the dot still showing.

Oh, how interesting! (Currently) the dots hide only when all notes in a chord are hidden! So it’s not the way you wanted it, and it’s not the way @mati wanted it either.

I guess for your case the next thing I would try is putting the lower note, not dotted, in a second up-stem voice, setting its voice column index to 0, and hiding the following rest. (Eurgh. Maybe there’s an easier way.)

1 Like

Hahaha! Of course I found a way to break it…

Also worth saying, Mati’s situation is nuanced and complicated. I would think mine would be fairly logical. Hide a note head, I’d think the dot would vanish with it. Maybe not? I’m no programmer for sure…might be a very good reason I’m not thinking of.

I’ll keep playing with it and try your tips here. I might just write a voicing out for now, but that doesn’t honor the original composer’s intent. Hmmm…

Thanks!!!

In the example, you still have the flat symbol to eliminate.
If you do not want the Db, why include it at all?

As noted under the graphic, I was only demonstrating the dot not disappearing—not the specific technique I’m working on.

Hopefully that answers your question.

I used a C under the Gb before on my own attempt. Dot still sticks around, so the problem persists.

The question remains, why do you need the invisible notes?

You can always create a Line that is the exact same width as your stem settings, then position it in Engrave. You can Alt-click them around too.

In any case, there’s no issue with the dot in that situation.

1 Like

From the Dorico 4.3 Version History PDF:

Rhythm dots are also hidden when the Hide notehead property is activated. Be aware that in complex chords of interlocking voices or where intervals of a second are present there is not necessarily a one-to-one relationship between noteheads and rhythm dots, and that Dorico automatically groups adjacent rhythm dots together for the purposes of positioning. Rhythm dots will only be hidden if all of the noteheads that contribute to the dot group have the Hide notehead property set.

It turns out that in this case (where the notes are a third apart, rather than a second), Dorico still has a single group for those two rhythm dots, so the dot for the lower note won’t be hidden.

There are lots of other ways around it, e.g. shortening that individual notehead by an eighth so that no dot is required; you can always lengthen its playback again in the Key Editor if you need to.

1 Like