Best Way to "Freeze" a Group Channel?

I’ve got a vocal path that employs one audio channel, “Vox,” that feeds four parallel compressors, each inserted into a dedicated Group Channel, “Comp 1” through “Comp 4”. To sum everything back together, the four parallel compressor channels feed a fifth group, “Vox Sum.” Vox and Vox Sum also have various EQs, de-essers, delays, and reverbs inserted into them.

This works well until I need to add another vocal track. My CPU can’t handle the load, so I must Freeze the prior vocal channels. But, of course, there’s no option to Freeze a Group Channel. The only workarounds I’m aware of are to either record the “Vox Sum” output to a new Audio Track or perform an Audio Mixdown of the “Vox Sum” track and import the resulting audio file to a new Audio Track. Both options are fairly time-consuming and tedious. Furthermore, recording a bus to an Audio Track is a bit buggy; you have to route things in an unintuitive way, and I experienced strange timing issues while the “Vox Sum” channel was necessarily routed to “No bus.” So, in fact, you must route, and then un-route things in order to get everything working again. Not ideal.

Is there a better way?

Any advice is appreciated.

In Nuendo you can record the output of a Group channel to a regular audio track. Should work in Cubase as well. Create the audio track and then select the group channel’s output as the audio channel’s input.

If only it were that easy.

When I add a new Audio Track, “Vox Sum Frozen,” and choose “Vox Sum” as the input, nothing is recorded UNLESS I set Vox Sum’s output to No Bus. [This appears to be a bug because there’s no logical reason why the Group Channel should be prevented from sending to the Audio Track. If I instead choose any other Group Channel as input, it works as expected.]

But then, once I choose No Bus for Vox Sum’s output, timing gets wonky - there’s a timing delay in playback of the Vox Sum track and the Vox Sum Frozen track until neither channel’s output is directed to No Bus. Weird.

RIP comes to mind. Check the options, „full signal path“ (without master) should do what you want without additional routing.

Otherwise you could replace your voc channel by a group and send more vocals into that group.

Thank you for that suggestion, but Render In Place refuses to render the Vox Sum channel. I’ve tried all four options:

  • Dry (Transfer Channel Settings) - Renders the top-level Vox channel, effectively duplicating it
  • Channel Settings - Renders the top-level Vox channel (with fader and other channel inserts applied)
  • Complete Signal Path - Renders the bottom-level Surround Out 5.1 output channel (Vox > Comp 1-4 > Vox Sum > Vocals > Master > Surround Out). Setting Vox Sum’s output to “No Bus” doesn’t break this chain, but simply removes Vox Sum from the render of Surround Out. Likewise, setting Vocals’ output to “No Bus” doesn’t break the chain, but simply removes the Vocals output from the render of Surround Out.
  • Complete Signal Path + Master FX - As above, renders the Surround Out 5.1 output channel.

I tried “As Separate Events,” “As Block Events,” and “As One Event.” This had no apparent effect.

As if that’s not enough, the option to Render In Place randomly grays itself out. Simple things, like Alt+tabbing (to compose this forum post in Firefox), or double-clicking on an audio clip to invoke the Sample Editor, will cause the options to randomly become unavailable or bring them back again. It took me quite a while to figure this out - thought I was routing things wrong, but it’s just a bug confusing things.

Never tried this with more than stereo tracks, but in theory RIP should fulfill the task. Gonna do a test myself with 5.1 which I rarely use (for phase coherent warping only if needed), I’m a stereo only guy…

I understand. Thank you for checking!

I wouldn’t expect a 5.1 setup to have any bearing on this because I’m rendering a 100% mono path. But, Cubase apparently looks downstream and makes some assumptions that aren’t helpful.

On the bright side, File > Export > Audio Mixdown… works. Annoyingly, Cubase still renders a 5.1 audio file from the specified mono channel but there’s no other surprises. I was half expecting downstream effects to be rendered as well, but no. It’s not at all convenient or efficient, but at this point, I’m just happy something works. In this instance, it helps to enable Split Channels. The mono signal ends up isolated in the Center channel and the rest can be deleted.

I would expect a stereo project to experience similar issues - mono Group Channels would be rendered in stereo audio files. If that’s not happening, then I might just submit a bug report. I seem to find a lot of these working in 5.1.

Thanks again.

Ok, rechecked RIP with ‘full signal path’ (without the master plugins) with a mono channel with sends to 4 groups with compressors.

Cubase RIPs to a stereo file with a stereo master/to a 5.1 file with a 5.1 master. In stereo both channels are identical, in 5.1 just the centre channel has signal, the quadruple overhang contains silence.
That’s far from practical - many users including me have expressed their wish for a simple checkbox in the RIP dialogue to determine the file format of the rendered file instead of automatically using the format of the master channel. Here we just can hope to get this implemented.

Exporting though produces a simple mono file with the ‘vox sum’-channel (instead of the master) plus ‘mono downmix’ ticked in the export dialogue. Should be easier than ‘split files’ > get 5 files just to delete 4 empty ones.

Thank you for your effort! That helps.

For the record, Mono Downmix isn’t ideal because the center channel ends up getting attenuated. For example, a 5.1-to-stereo downmix usually drops the center channel by -3 dB (per panning law?). As for 5.1-to-mono, I’m not sure what’s going on under the hood, but it appears to be attenuating the center channel by quite a bit more than that.

All the rendering is done on the mixer channels. So whatever that channel is, mono/stereo/5.1. That will be the sum.

The export is in need of a update.

I have 32 outputs. Setup as 26 mono outputs and 16 stereo. This gives me alot of flexibility when I do export. If you only have that master output. Export is a pita.

Also as mentioned the pan of a mono track will have impact when you use the option to mono downmix your master out. Depending on your pan law, If you pan mono and send to stereo, it wont turn back to its original value on a mono downmix of that stereo track. Only “perfect room” -6db pan law, will stay flat. But there is a simple solution of bypassing the panner. That will fix that issue.

At the moment the Direct routing is a bit so so… You cant simply just setup a extra mono output to mono sum a mono channel. As the channel dosent update pan to the extra slots and only first slot. So you dont get the mono to mono routing when you swap output, wich will move the pan to the channel on the mixer, so your level stays correct, you get mono-stereo-mono. It is silly, but workable when you know about it (bypass panner). Also this is post fader. You might not want that for a “track freeze”.

I like using oldstyle method. So if you setup a extra mono output in your project audio connections and send a signal to that channel, using channel sends. It will go mono to mono, so your levels will stay correct. You can choose pre/post fader level. Just export that mono output, and like magic you have a perfect export of the mono channel. And you dont have to do the extra steps of bypassing pan and messing with your fader, to get correct values. And now you have a solution ready to go, when ever you need it. Less steps, quicker workflow.

Sorry if this is a bit technical. And overload of information. But I have to deal with exports all the time. I would be in a mess if I dident have all my outputs. I can export whole sessions where mono tracks stay mono, stereo stay stereo, choose pre/post fader, pre/post/bypass pan and grab me some coffee while the daw do the work.

I cant imagine how much of a pita it must be working export with only master output. Export is in need of a update. Make it more flexible for the users with less outputs.
Have basic things like
select bypass pan/fader on tracks,
select mono/stereo export on tracks,
bypass automation on tracks,
bypass plugins on tracks…

And all options should be made as options for induvidual tracks in a multi batch export.

Anyways I hope this will give some pointers, to improve on your export :smiley:

OMG, I see what’s happening (under the hood) now! So, the format of the export is determined not by the content of the channel, but by the destination of the channel and is indicated by the channel’s displayed panner and meters. So, for example, if your mono channel is routed to a surround channel, you’ll see a surround panner and surround meters, and when you export that channel, you’ll receive a surround-formatted file, even though the format of the data passing through the channel is mono from beginning to end. It’s unintuitive - or downright illogical - but I get it now. By routing my Vox Sum channel to a mono Group or output, the resulting export is a mono file.

So, putting this knowledge to work, I revisited the Render In Place options and made some progress there too. First, I figured out that Render In Place operates on a selected Audio Clip (or one or more selected Audio Tracks, each containing at least one Audio Clip). To be clear, it does not operate on a selected Audio Track (or Group Channel) when that track contains no Audio Clips - the option to Render In Place will be grayed out. If it is not grayed out, then you’ve probably got an Audio Clip in another track selected without realizing it, and that will be the content that gets rendered.

When I routed my Vox Sum track to a spare mono output and chose Complete Signal Path, I received the mono file I was looking for. I also received a 5.1 audio file for the Surround Out output, because my Vox Sum channel has Sends to FX Channels that ultimately route to the Surround Out. So, if your audio path splits, Cubase renders each path to a separate file.

It would be much more intuitive if Render In Place operated on a selected channel (any channel - Audio, Group, FX, etc.) and simply rendered the output of that channel to a new Audio Track, without regard for downstream channels. Easy-peasy. As it stands, the current implementation is beyond unintuitive. Even with everyone’s help, it has taken me days to figure this all out.

Thanks a million, Reflection (and everyone)! This has helped tremendously.

BTW, I ended up creating three new Outputs: Export Mono, Export Stereo, and Export Surround. This way, I’m assured that my Export and Render in Place operations resolve to a dedicated audio path with no opportunity for inadvertent effects, for example. The Device Port for all of these is “Not Connected.” Unlike “No Bus,” Cubase appears to like this.

That is how many of us do it, taking the phantom Bus route :slight_smile: