BestService Engine within Cubase on a Mac

I recently upgraded from Cubase Pro 8 to Cubase Pro 13, along with the purchase of a new Apple Mac Studio (Apple M2 Ultra). This Mac is running OS Sonoma 14.4

Cubase installed without any problems, and seems to work perfectly. Now I am installing and upgrading my many virtual instruments and effects, which has gone very smoothly in most cases.

Now I have run across a problem with getting Cubase to see the BestService ‘Engine’ plug-in (v 2.8.1.60 —the latest version).
Engine works fine in standalone mode, but I can’t get Cubase to recognize the path, in spite of trying this in Cubase’s VST Plug-in Manager. The default installer path of Engine placed this application into my Applications folder, and I tried creating a new path in Cubase Plugin-in manager and navigating to it… but it remained grayed out or dimmed, and was not recognized as a virtual instrument.

I don’t know if this is a BestService problem or a Steinberg problem, and I have also tried different forums and don’t see anything matching my situation. I can’t find the answer anywhere at BestService.

Hi and welcome to the forum,

Is it plug-in M-processors compatible? If not, you would need to start Cubase in the Rosetta mode.