"Better" Knob Control for Track/VST Quick Controls using a Generic Controller and NRPN

Hi,

this is a quick guide for changing knob cc to nrpn for better quick control of parameters in Cubase 11, somehow this feature is not properly implimented into Cubase

it took me some time to figur it out, if you are in a similar situation, this might help:

so if you are looking for setting up a midi keyboard/controller as an universal remote controller but are disgust how the knobs cc’s handles the quick controls, maybe this thread could help you to get a more pleasent experience conducting Cubase,

but let’s be real, you will achieve much faster workflow with mouse&keyboard or dedicated controllers, so if you’re on a clock don’t waste your time with this

if you are in for the fun, check it out!


disclaimer:

-first comes first, all props goes to Miloslav Nepil, he posted the bugfix for this to work, check out this thread for a better understanding:
https://forums.steinberg.net/t/generic-remote-does-not-really-work-with-nrpn/115750

-for this to work, your midi keyboard needs an editor that can assign nrpn to knobs and scale down the stepsize or a translator like Bome (for the stepsize), otherwise nrpn is unavailble or rather pretty useless

-in this setup you wont be able to play with the keys nor pads, use them to trigger macros and/or commands, just configurate them to your taste in the Generic Remote tab

-i only did this on a Windows PC and with an Arturia Minilab Keyboard in Cubase 11, but maybe this guide can give you an idea for your setup

-it’s still a compromise between rotation speed and precision, so there is no perfect solution, and you have to tweak and decide for yourself what’s the right balance

-in my case the knobs don’t update when changing channels, this is a downside clearly, i use pick up mode for now


The Guide:

  1. Setting up the Controller:

-open your editor change cc to nrpn, assing every knob to a differet midichannel, and change the stepsize (data entry)

-than save the template and update your controller, in this case: store to Memory 2, close the editor

fig2

-open Cubase, go to Studio/Studio Setup/Midi Port Setup and uncheck In ‘All MIDI’ box for your Midi Device

  1. Setting up Track/VST Quick Qontrols:

-first be sure your Midi Controller has the right Overlay activated, in my case i press shift+pad 2 to activate Memory 2 on my controller

-in Cubase:

1.switch to Studio/Studio Setup/Track Quick Controls and select your Midi Device as a MIDI Input and check the “Pick up Mode” box
2.MIDI Status: switch from Controller to Ctrl-NRPN and set the Max Value from 127 to 16383, repeat this for as many knobs you have

3.Export the Configuration (via the Export Button) and open the .xml with the notepad and change x to x+16, in my case x=1, so 1+16=17, save and close the file
4.Import the new configurated .xlm (via Import Button) and check the learn box, click the Quick Control row you want to assign your knob to, it should be highlighted and turn the knob, you should get 16256 as an adress, repeat this for as many knobs you have
4.1 for VST Quick Controls: the learn fuction is corrupt, i had to manualy assign Adress 16256 and the Midi Channel, but the rest is similar (to 3.)

note: in the .xml file the Midi Channels are numbered form 0-15, 0=1 and so on, if you want to make the configuration directly and soley there, you have to keep this in mind


let’s see what cubase 12 will bring in regards of remote control changes, and midi 2.0 it’s on it’s way…so the future is near:)

Cheers folks

1 Like