Big time signature + independent time signature + bar number change

Hello

I use Dorico 2.2.10.1256 on a Windows 10 laptop.
My problem is a little tricky for it occurs only after precise steps.
I’ll try to explain the best I can what I did and what the problem is:

  • I created a file with big time signatures shown above the score (choosing the option in “Setup => Layout Option”).
  • I then created independent time signatures in lower parts (not the one just under the big time signature changes).
  • I created bar number changes on a bar with a big time signature change and no problem so far.
  • But, when I created an independent time signature change in the top part (the one just under the main time signatures), each time I made a bar number change, no matter where (before or after the independent time signature change in the upper part), the main big time signatures become normal ones (small ones in the top part).
    I created a file to show this. The bar renumbered “100” was created after the first independent time signatures and each bar renumbered “200” was created after the second independent time signature change (the one in the top part)
    https://1drv.ms/u/s!AmXvSWmFNi78jcoQ6-7fLRClemTwIg
    Here is a screen capture:

    Is there a way, to fix that (meaning, not rescaling and repositioning the big time signatures changes when I create a bar number change)?
    Or is there a way to manually write a big time signature where I need it (at the time signature change)?

By the way, is there a solution to show big time signatures changes at the same place where an independent time signature changes occurs in an other part?

Cyril

Sorry for the delay in coming back to you, Cyril.

It is the expected behaviour, for the time being at least, that if you create a staff-specific or local time signature on the staff above/on which a large time signature appears, large time signatures can no longer be drawn there. Unfortunately there’s no workaround for this. It’s also expected behaviour that if you have a local time signature at the same position but on a different staff to a large time signature, the large time signature won’t appear.

The long and the short of it is that, for the time being, you can only really use large time signatures in projects that use a single set of global time signatures, which I don’t think is an unreasonable limitation. It’s of questionable practicality to show a large time signature e.g. above the system that doesn’t apply to all of the instruments in the system.

Thank you very much Daniel

You’re right, but in my (very specific) case, I had to use an independent time signature just to create a repeat bar inside the main bar.
I then hid the independent time signature, so the only time signature showing is the main one, and it’s unfortunately a small one…
Here is a screen-print to illustrate:


And a link to download the file:
Big time signature + hidden independant time signature.zip (464 KB)
But that doesn’t answer my first question about bar number changes and time-signature rescalling when the top stave of a project has an independent time signature (no matter where in the score). I think that’s not intended, even though I should use standard size time signatures for the entire project:

"- I created a file with big time signatures shown above the score (choosing the option in “Setup => Layout Option”).

  • I then created independent time signatures in lower parts (not the one just under the big time signature changes).
  • I created bar number changes on a bar with a big time signature change and no problem so far.
  • But, when I created an independent time signature change in the top part (the one just under the main time signatures), each time I made a bar number change, no matter where (before or after the independent time signature change in the upper part), the main big time signatures become normal ones (small ones in the top part).
    I created a file to show this. The bar renumbered “100” was created after the first independent time signatures and each bar renumbered “200” was created after the second independent time signature change (the one in the top part)
    Here is a screen capture:

    Is there a way, to fix that (meaning, not resealing and re-positioning the big time signatures changes when I create a bar number change)?
    Or is there a way to manually write a big time signature where I need it (at the time signature change)?"

P.-S. Here is the file with time signature rescalling when I insert a bar number change, and the top stave of a project has an independent time signature (no matter where):
Big time signature + bar number change.zip (407 KB)
P.P.S. I only used independent time signature for independent repeat bars in my real (and very specific) project. So the only time signature showing are the main ones.

It is the expected and designed behaviour that you will not get large time signatures when using independent time signatures. My apologies if that was not clear in my initial reply in this thread.