BIOS settings for Cubase

Windows: How to set up and optimize a Digital Audio Workstation – Steinberg Support

If I’m reading all of that correctly I need to disable everything that makes my i9 CPU really fast? Multi-threading too? I thought the multi-threading was what allowed my system to take advantage of the multiple cores of my CPU? Am I wrong? I just disabled everything in the BIOS that is suggested, and my ASIO meter is more stable by my whole system is much slower. I used to be able to work in wavelab mastering while at the same time mixing in Cubase and have both open with no problems, now my system crawls doing the same with everything Steinberg suggests to disable in my BIOS. I find this really weird that Cubase doesn’t like all of these CPU features enabled. Maybe that’s a new feature we should suggest. That Cubase work AND take advantage of these features in newer CPU’s?

1 Like

Honestly, you shouldn’t need to do any special things in your bios. Especially with that cpu.

I routinely disable the onboard audio and a few other minor things like enabling power on over pci so I can use wol. That’s all.

I have a utility that stops cpu cores from parking fwiw. And my power scheme makes sure nothing goes to sleep.

The system flies. (Full sys info in my profile).

1 Like

OK, so Multi-Threadding/Hyper-Threadding is one of those features that will either work for you or it wont (cause problems or not). Many here swear by turning this off whilst others by leaving this on. Its one of those features where you need to test and see whats works for you.
My personal thoughts are, if you are experiencing a slower than usual experience then you should leave multi threading on.

Like @Phil_Pendlebury mentioned, your main concern should be to just disable the Onboard hardware you are NOT using. Such as OBS (if you have a dedicated sounndcard), If you have dual ethernet consider switching one off. If you have wifi and ethernet consider which is more valuable and switch the other off. Close off unused USB ports. Some boards still come with USB2 if you have no USB2 devices turn this off. These methods will help out on system resources. Every cycle counts right!

Switch on the performance mode in cubase, add exceptions for cubase to your firewall rules, Add a cubase profile into your gpu control panel and set this to Max/high performance. OR, Open windows settings panel and search GPU > Select Graphics settings > Add cubase and set the profile to High Performance.

Hope this helps.

All the Best! :beer:

Forgot to mention, when setting Cubase to you high perfomance mode what cubase is doing is activating windows high performance mode in the power settings and when you quit Cubase Windows returns to a balanced profile or user specific profile. The problem with this is when cubase crashes, windows will be stuck in High performance mode and you will have to then manully return windows to the Balanced performance mode else your system will sit idle running in high perfomance mode. Just something to note.

I’m using I13900k and the only thing I did in bios is disable wifi and bluetooth.
Cubase 13pro windows 11pro with just the windows drivers. So no core tweaking.
Works great!

1 Like

Yup absolutely do not disable Hyperthreading. The folks who think it helps are either on outdated systems or have some other issue. The article on our site is outdated now honestly.

Especially if you are using C13 or N13. There really should be no need to do anything.

Bluetooth can be useful (Waves NX etc.) and usually that is included in Wifi so I have that enabled. But totally understand that you may need that one off.

FWIW here is my complete list of BIOS adjustments that I make on every BIOS update. You can see the default states followed by the states that i set. It is nothing really, and absolutely no touching the cpu at all.:

  • Discrete Thunderbolt™ Support [Enabled]-[Disabled]
  • Power On By PCI-E [Disabled]-> Enabled]
  • USB Audio [Enabled]-[Disabled;
  • When system is in working state [All On]-[Stealth Mode]
  • CPU Fan Profile [Standard]-[Silent]
  • Chassis Fan 1 Profile [Standard]->[Silent]
  • Chassis Fan 2 Profile [Standard]->[Silent]
  • Chassis Fan 3 Profile [Standard]->[Silent]
  • Chassis Fan 4 Profile [Standard] >[Silent]
  • Water Pump+ Profile [Full Speed]-[Standard]
  • AIO Pump Profile [Full Speed]->[Standard]
  • Fast Boot [Enabled]->[Disabled]
  • Boot Logo Display Auto]->[Disabled]
  • Download & Install ARMOURY CRATE apo Enabled->|Disabled

Within Windows. CPU core parking all OFF.
Make you own power scheme.

I personally have all USB ports set to NOT allow Windows to disable them at all, (in device manager). I have found over the years that when Windows is trying to power down USB it can cause issues. I always have them all enabled but don’t allow them to be powered down.

2023-11-24_12-42-58

There are some items that I disable manually. For example, my Camera capture cards where I do not use the audio, only the video. SoundID Reference, is completely removed including all services, (using a script which I am happy to share) as I only ever use the plugin version, (not Syetem-wide). Also, the nVidia HD Audio. I never use it.

2023-11-24_12-44-17

And most importantly, as mentioned above. Add Defender Exclusions to SB folders, files, plugins folders and so on.

1 Like

I’ve been building and fixing PCs, Laptops, consoles, etc since 1995
So I have a little experience with computers

Disabling your CPU to have the effect of a more stable Asio
This could mean Your CPU settings were set wrong for optimal CPU performance in the first place, IE left on Auto settings

This could also suggest there may be a timing issue with the Ram
When Gen 3 was released there were problems with RAM running above 3400mhz, If you occupy all 4 slots of RAM at the same time.
So if you use the suggested XMP profile or use default settings you still get RAM timing issues.

Another area could be the storage devices like old HHD drives etc
The input and output speed of the device can affect the Ram
The OS should be installed on SSD or M. 2 Drives

My friend had a problem with a new PC he got from a specialist PC retailer in the UK in 2019, He was having problems with FL Studio randomly crashing to desktop,
The web browser was also randomly crashing seemingly for no reason.
He was tinkering with graphics card drivers and settings for days. running the graphics card underclocked seemed to make the problem better.

I had heard about the gen3 problems so I set the MoBo setting to how they should be set. and long story short
The system runs perfectly with RAM underclocked to 3400mhz
using 4 slots 8 GB in each slot.
The fix is to buy 2 RAM sticks @ 16gb each using dual mode, for his motherboard slots 2 and 4 only
Then we could use the XMP profiles with no problems running a full 3600mhz
even with extreme settings turned on it now runs perfectly.

I think disabling the CPU has had a placebo effect unless there is a problem with the CPU, there are lots of ways to test this though. YouTube CPU testing.

:purple_heart:

Great point about the RAM. Especially with newer DDR5 systems. They are notoriously unstable when using 4 sticks.

For me I have memtest86 built into the motherboard so it helps to give me an idea very easily without the need for other tools. But it is time consuming.

In one machine, I have 4 sticks of 32Gb rated at 5200 each. Very unstable when using xmp or any of the auto settings. Even when the ram is in the mobo qvl.

After a lot of trial and error and testing, various complex things like voltage adjustments etc. I found that simply lowering the ram speed brings back full stability. Lowering the speed makes so little difference on actual performance, it’s no issue. So my 5200 ram is stable at 4200. As you guys probably know, it’s all about the cas really. The speed difference is

The choice was that or just use 2 sticks only, totalling 64GB using xmp.

I decided to stay with slightly slower speed and larger capacity.

However, none of this really had any noticeable effect on latency and spiking etc.(I wasn’t having any in the fist place), it was just stability overall. Since this post wasn’t really about stability I didn’t feel all this detail was needed. I mean we could really fill a whole book with all this. But the main thing is, no need for any cpu changes in BIOS. And avoid overclocking of course, at least to start with.

Since we’re now qualifying with numbers, I built my first PC in 1987. I’ve always built my own systems and always will. Things were much simpler then. :joy:

1 Like