Bizarre MIDI issue...

sigh Me again. :slight_smile:

OK, having a weird problem: Cubase will recognize I have a MIDI controller hooked up as there is a little red vertical bar on the transport panel that will jump up and down as I hit keys in a new project. So I click “Add Instrument Track”. Brings up all the virtual instruments. From THIS WINDOW, I can select an instrument and preview it on my keyboard just fine. Sounds great. Soon as I select “Add Track”, the track appears fine and suddenly I get no sound when I press keys. No vertical blue bars anywhere, just the red one. I set record enable and monitor. I check the correct MIDI input and HALSonic SE outputs, I check that my bus is in stereo and set to the right outputs. What could I be missing?

Nobody huh? Great…

Why are you selecting add track?

Does add instrument track not just work with the selected instrument? you cannot add a midi track to play an already created instrument track!

You would need to use the instrument panel and add a midi track, that is different to an instrument track.

Maybe a good case for checking the manual?

I dunno, the OP may be onto something. I’m seeing a bug. I duplicated what he did on my iMac. This is what I started with:

Then this:

and…

and…

Then I hit Browse, picked a Preset and hit Add Track.

…and got this as a result:

You’ll note that instead of the Halion SE, the process loaded an instance of Nu Edge’s MicroTonic into the track , but the Preset is still Halion’s. So the only thing I can suggest to the OP is check the Inspector and make sure the instrument you chose is there. If not, re-select it from the Inspector and you should be good to go.
If you can’t see my entire screenshot from left to right, use your browsers ability to view the entire image.

How strange!!!

I think that the preset browser in the screenshots is browsing all presets for all VI’s.
(Notice how the instrument at the top of the window is blank. Also notice the “DS” prefix to the preset selected [DS = drumsynth?]. Also notice that no filters are selected)

As Sinta wrote: the preset browser (“new instrument track”) is browsing all presets for all VI’s.
So you can audition all your “bass synth” sounds e.g. - if you like one, apply, and voilá! - cubase generates an new instrument track together with the corresponding vsti.
Great feature!
I want it that way. And I love it.
:sunglasses:

If you want to display only compatible presets for a vsti:
Open the vsti you need and use the preset search function in this vsti window.


EDIT: oh!! sorry, you mean the Inspector vs. preset display! ok, this is strange… hm. I will check this on Win.

Central

Can also be done by choosing the instrument in the filters pane.

You can add an Instrument Track by either directly selecting an instrument OR click browse and indirectly add an Instrument Track by preset.

If you first select an instrument and then hit browse, the instrument selection is irrelevant, because now the instrument used on the new track will be determined by the preset you select.

An attempt to load a μTonic preset (DS AcidWaterDrips) into HSSE is illogical, not a bug.

I did EXACTLY what the manual said to do, step by step… More than once now.

Maybe I’m not understanding, so if I choose to add a new instrument track do I also need to add a MIDI track associated with said instrument track?

And if that’s the case, why can I preview the instrument just fine BEFORE I actually add the track? That makes no sense, can preview fine but after adding the track you can do nothing without adding more nonsense? If that’s really the case then that seems like a completely useless step in this whole process… In Reason, you select an instrument and it syncs with your MIDI input automatically and right off the bat.

I’ve also upgraded from Vista to 7 in the hopes it would help, waste of money so far.

Read the manual, watched the tutorials, I can see no reason why it’s not working… Getting frustrated, sorry for the rant folks.

No.

Can you provide a screenshot of the inspector of the track?

You can add an Instrument Track by either directly selecting an instrument OR click browse and indirectly add an Instrument Track by preset.

Normally, this is what I do. I rightclick in the track list area and choose Add Instrument Track, then pick a preset via the Inspector…which automatically takes care of the filtering. Simple enough.

My point (if there was one) was to follow the OP’s breadcrumb trail to see what he was getting. By doing it that way you can see how it may lead to confusion within the MediaBay. Directly after clicking Add Track from the minimized Add Instrument Track pane, the unfiltered full view appears, as the following screenshot point out. Without paying attention, I assumed the Search Results were HSSE presets and didn’t recognize that by selecting that preset would override the initial HSSE instrument selection (previous pane) and launch MicroTonic. An interesting feature at that.

So yes, total agreement: illogical. Not a bug.

But it does illustrate what the OP may have encountered…possibly explaining the lack of any sound playing. Hence: my “check the Inspector” advice. I can imagine others tripping over this. I did. But again, this roundabout method is not what I normally do to create an Instrument Track.

Certainly provided an enlightening experience.

OK, I’m hoping that someone here will have a facepalm moment and just say, “Do it like THIS, dumb***!” :smiley:

So first, I open a blank project. I then right click seen here:

I click, “Add instrument track” as seen here and in this window I can play around on my keyboard all day and get some fantastic sounds, circled the red and blue bars to show this:

So then I click “Add track” and get this screenshot here. And nothing. No sound, no blue bars but the red one still jumps when I press a key. Circled red bar, cirlced “All MIDI inputs” and “HALion Sonic SE” to show they’re good.

So what the heck am I missing?!

I think you actually have to have hit either the play or record buttons on the transport panel before you’re going to get any sound.

I don’t think so, I play VSTi’s in stopmode all the time.

It would appear not to be a bizarre MIDI issue, since Cubase is receiving the MIDI events.

Does the same happen with all of your VSTi’s?
Is Control Room enabled?
(Have you tried all combinations with the Record and Monitor buttons on the Track?)

You have " All MIDI inputs" selected as the MIDI input to the track. Select the specific MIDI device instead of “all MIDI inputs” or go to
Devices --> Device Setup–>MIDI Port Setup and make sure that the checkbox is selected for “In All MIDI” for the specific MIDI device you want to play from.

:blush:

Checked MIDI input to specific port, same thing. Can play in VST selection window but nowhere else.

Checked control room, it’s enabled.

Played with record enable and monitor buttons, same thing. Can’t play, record or play anything back.

:angry:

Tried disabling the CR?

Cannot record the MIDI events (not audio), even though the MIDI messages are indicated on the Transport?