Blank GUI

I just installed SpectraLayers 7 on Win 7 64.
When I run it, it asks me to enter activation code but all I get is a blank user interface with nothing at all. :frowning:

I uninstalled/reinstalled it but it did not help.
Any ideas?

What happens when you launch the eLicenser Control Center directly ? Can you screenshot the different licenses that it shows ?
It’s probably not related in this case, but remember that Win 7 is not officially supported anymore.

Same thing happens when I launch eLicenser Control Center directly.



Weird, the eLicenser dialog doesn’t even show the version number.
You can try upgrading to the latest eLicenser installer. SpectraLayers installs version 6.11.10.2272, now the latest available is 6.12.4.1273:
https://www.steinberg.net/en/company/technologies/elicenser.html
Then reboot your machine and launch the eLicenser Control Center (without launching SL). Let me know what happens.

I upgraded, rebooted and launched eLicenser CC and result is the same. :confused:

I’ve noticed that eLicenser uses NET Framework so I upgraded that too (v4.7.2 --> v4.8) but still so change in the blank GUI.

Ok, I’m forwarding your issue internally.

OK. Thanks for your help.
BTW I have figured out how to activate my SL license with a blank eLicense GUI. I’ve watched a Youtube video, clicked some blank buttons, after a few mistakes i’ve managed to activate it. Currently I’m photoshoping and sculpting audio like in Z-Brush. Amazing software!

Haha ok :slight_smile:
The eLicenser team told me this happen with some Windows 7 system language , such as Turkish or Azeri.
Switching your Windows system to english could have temporarily solved your issue.

Glad you enjoy the software !