Blank news hub with C12

You could try installing the eLicenser to get the news hub to show.

Why the news hub has this dependency is, well…strange.

1 Like

I’m on Win10 1909 and I also uninstalled Edge Webview but the hub is populated for me.

less is more. i do not need elicenser, so no news then :slight_smile:

Phillipus gave a way to fix with only a temporary install of the eLicenser. Why not try that?

I just mentioned it in this thread to let OP know he is not alone with the issue. And it also happens on Mac.
But just installing elicenser for news? Sorry, news is not important for me. But thanks for the suggestion .

The Edge WebView component that Cubase uses can be deleted or renamed so that links open in your browser of choice.

See Issue - Cubase 12 launch Windows Edge, not the selected default browser - #3 by Bjorn_Ek

Well, I can understand that. It seems strange that Steinberg is going dongle free, and yet the news hub depends on the eLicenser app…

:roll_eyes::grinning::roll_eyes::flushed::grinning:

it’s a strange bug indeed :smiley:

Strange, but I have seen something similar in the past. Developers probably take the ‘Why spend time reinventing the wheel’ approach for less critical things when under time constraints.
In my day job I work as an analytical chemist. The previous versions of the software I used to run on a lot of our instruments depended on the print spooler executable to create reports. That one is a little more obvious than the hub relying on the eLicenser but probably came about in the same manner.

I added it to the wiki as a bug

2 Likes

I just installed cubase pro 12.0.40, but the problem still exists.

Btw, Guy Michelmore made a great video about his experience with AS and Cubase/Logic.
He starts cubase and I see the same issue I had with a blank news around time slot 16:25. He do not mention it in the video.

bug still exists in 12.0.50.

bug still exists in 12.0.51

Same problem here 12.0.52 - usually have Chrome but reverted default browser to Edge, also tried renaming the WebView in C:\Program Files\Steinberg\Cubase 12\Components\WebView2Loader.dll as suggested in other threads.

What’s going on ? Win 10 latest still.

Same problem here (Cubase 12.0.52). Problem has started this afternoon. Problem exists with Chrome as default browser but also with MS Edge as default browser. I use Windows 10 Pro, everything is up to date… I have tried all the suggestions mentioned above in this thread, but no one worked…

The workarounds still work. I just installed C12 on a new Windows 11 installation. I did not use the Steinberg Download Assistant, I manually installed Activation Manager, Library Manager, C12 and the free VSTis.

Once installed I did this:

  1. Copied C:\Program Files\eLicenser\Tools\eLicenserCore.dll from the old installation to the same location on the new
  2. Renamed C:\Program Files\Steinberg\Cubase 12\Components\WebView2Loader.dll

The hub displays and links open in Firefox (my default browser).

I found that I had to re-sign in to the ILoK License Manager with my password then the hub window started to work again.

For me is the problem solved with 12.0.60.