Blank Render In Place when using Direct Routing - Workaround

If you use Direct Routing and have tried to use Render In Place you’ve likely discovered that it often produces a blank Audio File. This occurs when the Direct Routing is set to use any Slot other than the very first/top Slot. It doesn’t matter what destination the Slot is pointing to, only that the first Slot is selected.

I’d become resigned to trying to remember to temporarily activate the first Slot prior to Rendering (typically I’d forget until I saw the first blank Audio).

Today I realized there is a pretty straightforward workaround.

  1. Add a Group or FX Channel to act as a Dummy Track
  2. Make sure the Dummy Track is NOT routed to anywhere
  3. Enable Summing Mode on all your Channels which use Direct Routing
  4. Route the first Slot to the Dummy Track and use another Slot for the real routing