Blank video frame on tempo change

When I import a video in my project and I change the tempo, the first 17 milliseconds of the video become blank. There’s no difference in how I trim or cut the video, the first 17 milliseconds are always blank in the video preview window. This happens with both H264 and ProRes. Latest Cubase 11 on the latest Windows 10.

This is how to reproduce the issue:

  1. Create an empty project
  2. Import a video file
  3. Change the tempo to something that isn’t 120 bpm
  4. Place the cursor at the start of the video and watch the video preview window

Here’s a screen capture of the issue:

It does not depend on tempo.
This is due to the fact that in Cubase/Nuendo you are allowed to place the video anywhere on the grid like any other part.
The problem is that a video clip position in the timeline should not be unaligned to the Timecode grid, which would force the program to display something that does not exist: subframes!

Solution:
Before inserting any video in the project window, set the Snap Type to Grid, switch on Snap, set the ruler format to Timecode, then place your video clip.

You can then set the ruler to any other format for your audio/MIDI editing, but do not move or trim your video events in any other format than Timecode, Seconds or fps.

Thank you for the reply.

Well, this behavior is unacceptable for ‘music for video’ and sound design duties.
Every modern DAW allows you to place the video anywhere on the grid but doesn’t introduce that subframe issue.

Here’s the same video clip in Ableton:

The issue happens even when the video has been imported long after the tempo change.

Create project → Change the tempo → Import Video = The first milliseconds of the video appear blank.

Again, I don’t think this behavior has anything to do with tempo settings.

(by the way, you were right, “Show Timecode Subframes” preference didn’t change this behavior, only affecting the ruler. I removed misleading posts)

Well, the issue doesn’t happen if the project tempo is left unchanged, no matter how much you move the video around.

The bug is not present in Cubase 12.0.30 on a Mac.

Thank you Steinberg!