Bluetooth Headphone issue


I’ve been loving Cubasis, especially with the new sampler instrument allowing me to create my own kits and arrange my own midi drums, so first off, great work!

My only issue so far has been with my bluetooth headphones. They are multi-use, meaning they function has headphones, but also as a bluetooth headset for phone calls. It’s become clear that these two functions operate independantly. When I connect the headphones to a computer I see two different output devices, one for music and one for phone calls.

My issue is that when I connect my headphones to my iPad, most apps like any arturia synths, or youtube, etc, will produce audio from the headphones output and sound fantastic. When I launch Cubasis and connect to bluetooth audio, the headphones connect, but all my audio is tinny and sounds like it is coming from a phone call. My assumption is that cubasis is using the wrong protocol for connecting to my headset. Is there anyway for me on my end to fix this? Or is there possibly an easy fix on your end? Thanks in advance

The headset in question is the Creative WP-350 Bluetooth Headset.

Hey Brandmo

I can’t answer directly why Cubasis sounds weird. BUT, using Bluetooth monitors with any DAW is generally not recommended. Bluetooth audio has a significant amount of latency. While it works with streaming video, I don’t believe most realtime audio recording apps can compensate for the delay, and it makes recording virtually impossible. Wired monitors, at least for recording, is really the way to go.
I don’t intend to criticize your approach, but there has been a good deal of conversation regarding the pitfalls of Bluetooth, and I wanted you to be aware there are problems beyond the problem you asked about.

I’m aware of the downfall of Bluetooth, but it’s been included in cubasis because it’s a useful resource and allows your iPad to tap into different audio settings. I don’t record when I’m using Bluetooth, it’s fairly helpful when checking a project on different speaker setups or little tasks like auditioning samples and building sampler instruments.

Hi BrandMo,

Cubasis has been successfully tested with several BT devices (speakers, headphones) and we’re not aware of any issues so far.

This is the regular way to go:

  • Make sure you have turned on Bluetooth in the settings of your device in use
  • Double check that the corresponding Cubasis option (Setup/Audio/Bluetooth/AirPlay) is activated
  • Pair the device with the BT accessory


Hi Lars, could I perhaps write up a bug for you guys? I’ve tried other bluetooth devices that seem to work great, but on this specific device, I always have issues. I believe this may be an issue for other devices with dual phone call / music playback functionality. Of the devices tested, did any by any chance have the ability to also take phone calls?

My bluetooth speaker doesn’t work well with cubasis (jlab crasher,iPad air2) the sound is bad, other audio apps sound good though.

I presume this is caused by my same issue. Your speaker has separate protocols (or different audio units even) to handle phone calls versus proper audio. It’s still my belief that cubasis does not recognize separate protocols and this causes issues. I understand it not getting fixed right away but it would be great if you guys at least acknowledged it was an issue or looked into testing on a few more devices.
Would be greatly appreciated. :slight_smile:

I have solved the same problem with my new SONY SBH60 BT headset now. When BT device support both audio in/out, iOS playback sample frequency is reduced by two-way “phone” codec in the BT device. Default mode of my SBH60 is a “headset” and his internal microphone is active. In this mode, BT headset works with “phone” low sample frequency codec (in my case about 16kHz) and music playback quality is horrible!

When BT headset is in one-way headphones mode (internal microphone on the headset is inactive), BT headset-headphones works on high sample frequency codec (in my case 44kHz) and sound in the headphones is amazing.

Most of iOS apps have a perfect sound in the BT headset as default, because these apps do not use audio-in, but only the audio-out and therefore only applies headphones mode and codec with high sample rate = perfect sound. But Cubasis uses audio-in and audio-out together.

In Cubasis can be mode set there: Setup / Audio / Bluetooth - Airplay. When the switch is “on”, the sound is perfect from my SBH60. But microphone is disabled, because headset works as headphones (audio-out device only). When the switch is “off”, paired SBH60 is automatically used for recording too (audio-out/in device) and playback is horrible, because Cubasis uses SBH60 in two-way mode with low frequency codec.

Solution: For quality audio out on BT headset must be this switch “on” (Setup > Audio > Bluetooth / Airplay > Bluetooth / Airplay Output) When switched “on”, Input device is set to None.

Problems for improvements in future versions of Cubasis:

  1. Essential and big inconvenience is that Cubasis can’t remember this setting and must be set manualy every time when Cubasis is started. Too uncomfortable!

  2. If this switch is “on” (for quality audio-out plyaback) and audio recording is started on some audio track, Cubasis automatically switch this to “off” and uses BT headset for recording. That’s fine, but when recording is finished, Cubasis does not set the switch to its original state. Unfortunately switch remains “off” and must be set to “on” manually again. Too uncomfortable!

I hope, that this issues will be fixed in some next version od Cubasis.

Described findings are for the iPad Air 2 and SONY SBH60. But I am convinced, that this also applies to many other BT headsets. For information and advice on this issue, thanks mainly to AudioShare app support!

Hi peeps,

I have a similar issue but actually with Cubase 6. Does anyone have any suggestions how to remedy this? I disabled my mic through my sound playback on my computer, and it shows inactive in the Device Setup. It actually sounds like it’s playing at a slower pace than it should as well as really bad. I have the Sony MD-ZX330BT headphones. I understand it might just be a quality issue but it plays fine with all other audio playback than Cubase! Please let me know, thanks.

Hi MathiusJ,

Please have a look at the Cubase forum regarding this topic.