Blurry, low resolution in Cubase

Hey,
Right now I’m trying to choose between Ableton Live 10 Intro and Cubase Elements. I like Cubase more because it offers more tracks but I wasn’t sure. I downloaded the trail versions for both. Ableton was good but Cubase was very blurry and had super low resolution. I looked it up and it said to activate HIDPI mode. When I did, it became less blurry, but it also became big and I couldn’t physically press most of the buttons/options on the software.
My question: Is there anyway to make it less blurry? If not I’m buying Ableton.
Tech Specs: My screen is 1080p and my resolution when I tried Cubase was full HD. 14 inch laptop screen. Windows is my computers operating system. I am on the trial version of Cubase.

Hi,

As far as I know, 1080p is not HiDPI, so I wouldn’t recommend to use HiDPI settings.

Could you try different screen resolutions, please?

That depends on the size of the screen: 1080 on a 49" tv (45 dpi) is definitely not hidpi (ie High Dots-per-Inch), whereas 1080 on a 5.5" iphone screen (401 dpi) is.

In this case, you’re correct in that 1080 on a 14" screen (157dpi) wouldn’t really be considered hidpi (which is usually taken to mean something around 300ppi or above) but as mentioned above, it’s entirely dependent on the size of the display.

If Cubase looks like it’s “low resolution and blurry” that would suggest that the OP maybe has Windows scaling switched on? And we all know how poorly Cubase handles scaling - if it’s scaling itself to 200%, then it’ll definitely look terrible on a 14" display.

Yup try scaling at 100%
No blur here at 1080p (on 2 24" monitors)

It’s your laptop settings.
Laptops have text, apps and other display settings cranked up to 140% (as default) usually in Display Settings option in Windows.
Go there and change it to 100% and everything should be sharp. Including all windows apps and programs.
The downside (for some) may be the everything (text, icons, etc…) becomes smaller and if you have any problems with your eyes it may be difficult for you to read.

buttons look really blurry for me. anyone know how to fix?
https://imgur.com/xgnwcSp

Hi and welcome,

This is a known Windows issue. It has appeared few times here on the forum. Please search. You can also use Google to search, it’s not on Cubase side at all, you have to tweak something on Windows side.

Hi there!

For those of you experiencing the blurred/pixelated effect on Cubase 10.5 - Close the program, go into properties and choose to run the program in compatibility mode for Windows 8, hit apply and the issue should be resolved.

As highlighted by other members, there is something with Windows 10 that Cubase 10.5 doesn’t seem to like.

Hi and welcome,

I would like to mention that Cubase 10.5 officially supports Windows 10 only. So if you start it in Windows 8 compatibility mode, you are out of the supported setup.

Most probably the blurred issue is linked with HiDPI and the settings.