[BON-8590]Render In Place Multiple Outputs Issue


I have a problem with Render In Place.

I added EZdrummer as a Track Instrument and assigned all 8 outputs. Output 4 and 5 were assigned to Tom 1 and Tom 2 but in the end I did not use them in the song. Therefore I disabled outputs 4 and 5.

Now when I Render In Place it will only render outputs 1,2,3 and 6 and output 7 and 8 are skipped/ingnored?
To test I enabled outputs 4 and 5 and Render In Place nicely rendered all 8 selected channels.

To exclude EZdrummer as a culprit I replicated the situation with Groove Agent SE and it’s the same.

Steps to reproduce the issue:

Step 1: Add Groove Agent SE as a Track Instrument
Step 2: Choose a kit and create a drum part on the track (I just used one of the patterns)
Step 3: Activate outputs 1,2,3,6,7 and 8
Step 4: Assign pads to the active outputs
Step 4: Render In Place (I did dry)
Step 5: Notice that only outputs 1,2,3 and 6 will be rendered and 7 and 8 are skipped/forgotten

In addition try to activate outputs 1,2,3,4,5,6,7 and 8 and render in place. Now all 8 outputs will be rendered.

Best regards,


I can confirm that this is happening.

Hi… Outloaf… Thanks very much for your confirmation.

Will anyone of the Steinberg team respond. I believe this is a bug or an issue at the least. How does this work? Does the Steinberg team investigate the reported issues? There are not so many issue reports (which is a good thing by the way) so it would be nice if these reports are being read and investigated.

As a customer taking the time to report so a product can be improved it would be nice to get some feedback from the manufacturer. I nicely describe the problem with clear steps to reproduce but get no response from Steinberg for almost a month. Is this the wrong place then or should I have no expectations?

So please Steinberg… I would appreciate some feedback on this issue. It makes assigning outputs less versatile for the new Render In Place function. Oh… I wish it was implemented in Cubase as it is in Sonar. Just some kind of Freeze function with a usable waveform that is visible after freezing instead of an invisible wave chopped to pieces to preserve some diskspace. Just quick simple and userfriendly. But yeah… that’s a bit of a personal wish…

Thanks in advance…

Hi… So allmost another month and still no response from Steinberg. Why is that?? Am I posting in the wrong place here or do they just not care?

Almost a half a year after release I still cannot use the RIP as desired! This was the main reason I upgraded but this bug (well… still have not confirmed it’s a bug but it sure looks like it) together with crashes while Rendering in Place and the fact that you cannot disable an instrument track after RIP without destroying the possibility to use the normal Freeze funcion makes it at the least unpleasant. Disable Instrument Track was told to be fixed in 8.0.20 but we are almost a half a year on the road with version 8 now!!!

Is this it? I also asked if I’m posting in the wrong place here but cannot seem to get an answer. Steinberg is one “Black Box” for me. No support???


This has already been reported I can confirm it is a Bug. The work around as you mentioned is to activate all Stereo Outputs.

I am moving this to the collected issues.

Best regards,

P.D. Please have in mind that just because some times we do not have the time to replay to all the threads in the forum, it doesn’t mean we have not red the thread or reported it to the developers.