Booklet printing snafu

So until about Dorico 1.2 (I can’t remember exactly which version, might have been until 1.1.10, either way it was until whatever version the paper size descriptors in Print Mode changed) I was able to print booklets on ledger paper (11x17) with no problems. Since then, I haven’t been able to print properly-imposed booklets, and the output doesn’t match the preview in Print Mode.

First try (these are the settings that used to work properly):



Second try images posted in reply. Anybody know what’s going on here?

Second try:


I also have trouble printing booklets from Dorico, in all versions. I just export to PDF and use my printer driver’s booklet feature. This adds an extra step, but it works.

1 Like

Certainly it works, but it’s not ideal! If the software has the feature, we should be able to use it reliably.

I’ve created a second printer installation with (in my case) 11"x17" paper set as the default size (forcing Dorico [and Sibelius]) to recognize that as the first size available. I’m able to print booklets easily enough if I use that printer definition (and check the paper size selection for EVERY part before printing). YMMV

I believe there is a bug open in our tracker concerning this issue – we do plan to fix it.

Another snafu-- you cannot print only a subset of pages as a booklet. I have multiple flows in a project, but I’d like to only print pages 1-4 as a booklet for immediate use. That option is greyed out when you select booklet as it forces all pages to be printed.

Yes, it is the current designed behaviour that you can only print the whole document as a booklet at the moment.

I just found this thread, having been curious about printing just the first (outer) pages of a booklet score:
LAST PAGE | FIRST PAGE
2ND PAGE | PENULTIMATE PAGE
Daniel, is there a plan to implement this? I don’t want to waste so much paper.
Maybe there’s a workaround?

Answering my own question—export a pdf, then print only the pages required

1 Like

Best way is to export as a paged PDF, and then create the booklet from there, and then print the spread-pages you want n a PDF Viewer.

There are any number of ‘Imposition’ utilities, particularly on MacOS, to do this. I’ve even written one myself:

https://github.com/benwiggy/PDFsuite

Daniel acknowledged the bug in 2018… still no solution? Booklet settings are STILL messed-up!
https://www.facebook.com/groups/dorico/permalink/2780127692264965/

WimLas, are you referring to the ability to print only part of a layout as a booklet? If so, that’s not a bug. If you’re instead referring to the page order for outputting booklets, we added an option to the right-hand side in Print mode to send the pages in reverse order, ‘Reverse order of outward pages’.