bounce or export deletes/resets Free Warps!

Hi,

I think I have just found a bug. Tried it on two different machines (both running Cubase 6.0.2 32-bit on Windows 7 64-bit). The same thing happens in Cubase 5.5.3.

Reproduction:

  1. Open a up an Empty project
  2. Add Audio Track (Stereo)
  3. Import a Wav-file via File/Import Audio File… (doens’t matter if its a “clean” wav or in ACID format, I already checked that).
  4. Duplicate the audio track.
  5. Double click the sample, on the second audio track you just created, to open the Sample Editor.
  6. Choose AudioWarp and Free Warp.
  7. Do some really obvious Free Warp’ing.
  8. Bounce it and compare the two wav’s. The work you just done is completely gone! (the warps are not applied!)
  9. Try the same thing but Export as Wav file. Same thing happens! Realtime or not doens’t matter.

Doens’t matter if I choose Musical mode on the files or not either.

This is a huge issue for me since I use Free Warp in every project I work with.
cubase_bug_freewarp.jpg

Also, I know that more people have this problem.

Here is another thread about it:
https://www.steinberg.net/forum/viewtopic.php?f=19&t=9176&hilit=free+warp

(btw, trashing all the preferences does not help!).

Today I tried this on a third computer also running Win7 64bit+Cubase 5 32bit. And it is not working, it moves the free warps when bouncing, so the result is different BOTH from the original file and the free warped one. It is definitly a bug.

Hi,

Cannot confirm this here.
What I did notice though is, that if you compare the bounce to the original - but warped - file, there seems to be no difference.
Of course that is so because the warp edits are still present in the original file until you perform a reset.
Are you sure this is not what you are overlooking?

Hey,

I’m not sure I understand what you mean, the bounce of the warped file SHOULD be the same, that is the whole issue.
I expect the warps to be applied when I bounce or export and not reset.
Did you duplicate the original track like I did in my screenshot?

The only way around this is to route the audio track with the warped file to a new track and hit record. That seems to work… although I have only tried it once.

So you say the applied warps are not in the bounce, so it equals the original unwarped file?
Can’t confirm that here, seems to work as supposed…

That is weird. What version of Cubase are you using? I have tried this on three computers and different versions (both 5 & 6) of Cubase with the same result. Did you do it exactly like in the screenshot (duplicate the original track)?

Bump. Anyone else tried this?

I could not reproduce with freewarp values that are in the borders of the freewarp limitations.
I can reproduce if I applie extreme freewarp value settings but it is not a bug that the freewarp is not rendered into the bounce:

Freewarp is a real-time process.
Consider that if you freewarp with extreme values you get the following notification as transparent overlay:
Realtime algorithm has been deactivated because pitch or stretch factor lies outside the limits of the current preset

Notice that the waveform visually remains warped but if you listen to the event you will realize that the warp process is actually turned off. That is the problem.

Either this is a display bug and the waveform should also visually snap back to the original once this notification message occurs or extreme freewarp values should be settable without deactivation of the realtime algorithm and the notification should not appear at all.

Gr,
JHP

Thank you very much for the answer!
I will check again, must have missed that notification ( every time…? :slight_smile: ), and I didn’t really listen to the waves - I just looked this time.
Sometimes realtime stretching with extreme values are exactly what I’m looking for (to make really cool glitches/timestretchsounds-by-choice)…

So the bug is only that it DISPLAYS something that is not played back, ie Cubase should go back to the original waveform after the free warp warning is displayed. :slight_smile:

Information about it here:

https://www.steinberg.net/forum/viewtopic.php?f=175&t=37118

It’s not just the display that is wrong.
I did listen, and my edited bass track was in perfect time after audio warping but definitely out of whack after a bounce, export, or flatten, by as much as a sixteenth note.
Actually, the display is quite close to what I’m hearing so that’s not the problem.

I am relatively new to Cubase, and I had this issue as well when warping a bass track. I would receive the message “realtime algorithm has been deactivated because pitch or stretch factor lies outside the limits of the current preset” and my audio would not match the waveform I saw in my sample editor. I, too, thought this was a bug and agree with others that the display in the sample editor should change to alert the user somehow.

I don’t know if this will help other newbies, but here’s what I did to fix without a lot of hassle/workarounds:

  • *Check my warps for extreme time changes. I had a few sections where the bass guitar string was stopped, and I wanted a sustain to the next note. Thus, I warped the audio at the end of the note to the start of the next note leaving the smallest possible gap between notes.
    *When locating the extreme changes, move them back to a position that was closer to the original time position.
    *Do this for all extreme changes until the error message disappears. You can also hit the “reset” button to reset all warp changes (this is what I did).
    *Now go to one of the changes you want to make and move it a little bit at a time toward your desired position, checking for the message to appear again. When it appears, retract in the timeline slightly.
    *Stop warp just short of where the message appears.
    *Repeat for needed warps.

If you follow this procedure, you’ll notice that your audio matches that in the sample editor. For me, I was effectively erasing the bass note stops with audiowarp. However, like the problem others have described on this thread and in other threads, I still heard the original, unwarped audio. This is the normal function of Cubase when you “over correct” using audiowarp past where the algorithm can handle it. This may not fix all of the issues others see, but it fixed mine perfectly without flattening, etc.