(Boxed) text and avoid collisions

Hi, what’s wrong with this picture?
Before (version 2.0 and earlyer) I had the systems go out of the way when I inserted a default text (boxed or not)
But now nothing will be avoided and the button “avoid collisions” is gone.
I have the button in Engraving options text to avoid collisions;
Is it not possible to avoid collisions wit lyrics?

You can set the “avoid collisions” property in Engrave mode, but not in Write mode.

You can also set the default value in Engraving Options / Text.

Yes, I have steen that.
But why is the text not avoiding anything?

Can you attach the project, please?

Hello Daniel,
please take your time to look at this;
And thank you and the team for this wonderful program!
The 2.2 update is amazing!
kind regards,
Herbert van Essen
Psalmen.zip (619 KB)

The reason for the collision is two-fold: firstly, Dorico only considers the top edge of the box around the text, and secondly, the bottom line of the staff of the system above isn’t considered for collisions either. So this is basically working the way things are designed, at least for the time being.