Brackets not enclosing accidental

When I write

in my ‘standard template’ the accidental is not enclosed on the first note, but when I use the default Dorico template get

What setting could I have activated that does this incorrect notation?



You should have a fiddle with the Library Manager and see if you spot anything when comparing vs default.

What happens if the cautionary accidental on the pink note above the staff is removed?

Nothing. I will DM the score to you to see if you can spot anything. I changed all the accidental ( ) settings but it had no effect.

When “fiddling” with the score (copy/paste) I inserted a treble by mistake, and then Dorico does it correct;

Something is odd, but I cannot understand why.

Yes, that’s odd. (PS I received your score)

I also noticed that if you change the scale of the note, while still in bass clef, from cue to normal, then the accidental jumps back inside the brackets.

You should upload your project here so that someone else can offer guidance. Cut the project down to a few bars - I just did it and the problem still exists.

Here is the project, with both bars.
x02025.dorico (661.4 KB)

Interesting. At 78% it makes the “jump”. A bug?


I do not know if that is a bug, but i think the setting in:
Engraving options>Notes>Ledger lines>Ledger lines on notes with accidentals> “Do not adjust ledger lines” has something to do, because if you choose “Shorten ledger lines” insted (the default by the way) then the accidental appears inside the bracket.

Interesting. I think it is a clear bug. That setting should have no effect on this matter. As @DanielMuzMurray pointed out earlier, changing the size also makes a change. There must be some threshold in the code that places the ( ) incorrectly for different values and/or tries to align something with other voices.
Also, removing the accidental in 1st voice above the cue note, makes it work as expected. There is some incorrect ‘relation’ between these notes.

Further, setting the top note’s accidental columns to 1 (which shifts it a tiny bit to the left), while maintaining the “unset” or =0 for the cue note makes the appearance correct.

There is some bug going on with accidental columns, note size, ledger lines etc. that need to be sorted out by a developer. Several causes seem to affect the result.

Here is the result of changing the accidental column;

The spacing is cramped and does not look good.

My cue notes are set to 70%, but changing the size to the threshold value 78%, with no changes of the accidental columns, results in

which have a much more pleasing layout, except for the larger size of the cue note.

Hopefully, all this can be fixed in the next(?) update.